News | Forum | People | FAQ | Links | Search | Register | Log in
New Q1SP: The Bonehoard
So here it is, my first map.

You begin in a small outdoor area with a cave nearby, soon descending into a hellish stone/metal structure filled with rivers of blood and bone, and decorated with the mangled bodies of previous intruders. Will your corpse be added to the collection? Play and find out....

This map requires Quoth.

Enjoy! Hopefully...

Comments and demos would be greatly appreciated!
First | Previous | Next | Last
Can you repack the file without the folder, so it can be used with the Quake Injector?

Not bad for a first release. Feels a bit like Doom map in style with its nonchalant combination of textures from various themes.

I think it could have been done without exceeding the vanilla limits, but that shouldn't be a concern right now. Tip: if you have large void rooms with solid black walls, increase the texture scale to something high (like 99) to lower the polycount. Check with r_showtris 1 to see how QBSP produced many polys where it could have been two per wall.

Lighting is quite flat, don't use minlight. For example, the death pits should fade into black instead of showing the bottom. Some areas look unnecessarily "low-fi", because the lack of contrast highlights their simple architecture.

Gameplay is tough but managable on hard skill, plenty of ammo, and some cool secrets. I immediately made the connection between the RL and the pent at the beginning, but unfortunately didn't find the way to get the RL.

Careful when using fiends (and dogs) on uneven ground, tight walkways or areas with gaps in the floor. They can't land properly if the floor bit is too small for their bounding box to fit which makes them keep jumping and this can lead to instant death if they hit the player.

I encountered a strange bug in the room with the Edie/SNG secret above. Picking up the rocket box warped me into the adjacent room and I got stuck there as if trapped in a push trigger, unable to move or shoot. Even noclip didn't help. Preach please.

Newbie tip: Load the map with "developer 1" to see console warnings for monsters stuck in walls and items falling out of the level. 
Sweet Mother Of Fucking Christ. 
Upload it to Quaketastic or anywhere that gives a direct download link. 

Obviously some neat ideas but the theme, or rather the lack of it, didn't inspire me to continue. Assuming monster count is right and this is rather large, it would be better to focus on a smaller map and expand on the better ideas with a stronger coherence. 
Down In The 
Aw man, new SP release right when I am heading out of town to get married.

Will definitely have a demo for this when I return, the description is rather interesting. 
Congrats, man! Have a nice wedding. 
Blank Killtargets Again 
I encountered a strange bug in the room with the Edie/SNG secret above. Picking up the rocket box warped me into the adjacent room and I got stuck there as if trapped in a push trigger, unable to move or shoot. Even noclip didn't help. Preach please.

This is yet again the bug where an entity has a sero-length string for a killtarget, as featured in
In particular, the box of rockets behind the vore has "killtarget" "", and when you pick that up the player entity (plus most of the level) gets removed. Your view gets reset to the centre of the map, but you can't do anything because you've been removed.

I swear it must be that a new editor or compiler is making it easier to create one, because this bug has existed for 20 years now, but it's only in the past few months that people keep hitting it.

lpowell, if you revise this map, you can fix this bug by deleting the killtarget key from the box of rockets in question. This will avoid players being unable to complete the level. 
Or An FGD 
I believe that if you create an Fgd baseclass for Killtarget and use a line like this:

killtarget(string) : "Remove target" : ""

instead of
killtarget(string) : "Remove target"

But that would cause the error for every object placed that includes that baseclass since the default "" would be put in.

You could be right that the method that a newer editor parses blank key|value's will put "" in. 
Thanks for clearing that up. More like Trollbroom. The entity in question also has a "" "" field.

Lane: If you decide to repack the map, feel free to fix this issue along the way.

Also a reminder why playtesters are important. 
@negke: Thanks for the demos and comments, really appreciated. I'll fix the rocket box bug (thanks Preach! must be TB, I never intentionally added a killtarget value to that thing) and a couple other things I noticed in your demo (d'oh!).

I didn't actually use minlight, if by that you mean adding a "light" key to worldspawn--the ability to see the black death floor in that initial cave area is probably due to excessive light coming from the lava. Maybe I'll try to tweak it.

In general my strategy with lighting was to mainly use entities with light values between 200 and 400 and delay 5. I experimented a bit with other delay values and no delay but had a lot of trouble with it in general--no delay seemed to consistently make everything overbright and washed-out. I tried to go for dark lighting but it ended up looking flat in many areas, though in other areas I thought I made some nice shadows. It's a tricky balance I obviously failed to strike in many cases.

As for the RL secret at the start--you *just* "missed" it! But yes, there is a connection between in and the pent, which you apparently guessed.

@Shambler: Thanks for the demos as well, they're still very helpful even though you didn't continue. My next map will indeed be smaller, and hopefully more thematically coherent--at least this time I have a clear idea beyond just "I want to make a map!" This map isn't that large, though--monster count is inflated by a nasty trap and the final battle arena.

@Bloughsburgh: Congrats! Here's to a long and happy marriage. 
TB doesn't add properties to entities all by itself. If it does, it's a bug. If you can reproduce it, please submit a bug report on github. 
In the early days of Quake editing, while I was working on Polygon Base, I had one room suddenly become very bright.

It took me a while to figure out what was going on, because it was a small monster closet trap room with only one very dim light entity. Eventually I noticed I'd somehow given one of the enforcers in there a light value of 500 /facepalm 
I don't know how other editors work (why am I so turned off by 2D Views???) but in TB the issue pops up a lot because of how the key editing interface is designed. The only difference as far as a user can tell between a key with " " in it and a nom-existant one is whether or not it is italicised, and the fact that it will appear above all other keys which are nom-existant. I figured this out eventually, and so now I take special care to press the little minus button instead of clearing the text field like I used to, but even now my editor issues view is full of blank key warnings from months of not understanding this.

I don't really see this as a bug, more as an education issue, but perhaps the editor could automatically remove keys with blank values... Risking, I suppose, the support for weird map hacks. 
JFC my phone turned non-existant into "Nom-existant" TWICE 
I have made the same mistake (clearing the text field intending it to delete the key). I put some ideas on github here: 
WC/JACK/Hammer Behavior 
is to remove any blank keys that are defined in the fgd but have the input as "". 
A Great First Map 
A very nice map for your first release, you clearly know the basics of what makes a good single player experience. Basic, but clean brushwork and interconnectivity, coupled with challenging but fair gameplay. Lighting of course, being the weakest aspect here. With regular updates to tyrlight and a page full of lighting options to choose from, it can be a bit overwhelming to newcomers. But as anyone will tell you, the more you use it and experiment, the better you will be in the future.

First run demo, hard skill. I technically died at one point, because I fell off into the void.

With an admirable first map, you have the potential to only improve your mapping skills in every aspect from here on out. 
Thanks a lot ORL! I'll get to your demo (and Jaromir83's, which I missed earlier) tomorrow.

The zip file in the drive has been replaced with an updated version. Only two changes affect gameplay, one being the infamous rocket box, the other being a pair of health packs in the final arena (skill 0/1 only) that fell out of the map. The others are purely cosmetic, including the odd sliding button negke pointed out, and the lighting in the initial cave area that gave a lovely view of the rocks connecting with the void.

The archive should be good to go for Quaddicted. 
Great to see a new debut, even more so because it is for one of my favourite mods. And thank you for your trouble with the update.

First playtrhough in five parts (skill 2).
Twice stuck, twice dead in the final arena.

There is a screenshot in the zip. Loading the map in 'developer 1' it shows 4 items falling out on skill 2. (QS-0.90.0 32-bit). There are 4 'walkmonster in wall' reports too. There is a drole with teleport flag but no targetname.

Update: the latest version has the drole and the pair of health fixed. 'Item_spikes' and 'item_armor1' still fall out though. And the walkmonster reports persisted. 
Ill check it out later. Probably will delete those items as it plays how I want it to. Hold it for qyaddicted, negke... 
Ok, last update. The console actually still reports that error for two of the monsters, but they don't actually appear to be stuck, and behave as I would expect normally. Actually that was the case to begin with, so whatever I guess.

Get that shit to Quaddicted. ;) 
I can't get the demos to work. I put them in the \quoth folder and tried both with DP (20140430 build) and QS 0.92 but to no avail. QS console only returns an "error: couldn't open [filename]" message and DP displays a wall of hexadecimal code apparently pertaining to sounds (a bunch of .wav files is listed in the rightmost column).

Ideas, anyone? 
They probably don't work with the updated version of the map. 
I can reupload the original if you want 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.