News | Forum | People | FAQ | Links | Search | Register | Log in
OBJ-2-MAP V1.1
So I added a few new features to my OBJ-2-MAP utility and put together a small web page explaining how to use it.

This is a utility that can take OBJ files exported from any modeling app and convert the geometry inside into Quake brushes.

http://www.wantonhubris.com/obj-2-map/

Have at it! I think everything will work.

[edit: updated url]
First | Previous | Next | Last
Khreathor 
does that actually compile and work in game? 
Blitz 
I haven't got time to compile and test it in game, but with BSP2 it should work without a problem. 
Hahahaha 
 
Blitz 
 
Wow!!! 
Looks Great! 
Now make a quake level! 
Omg 
omfg 
 
now all it needs is arghrad-style phong shading. 
And A Shub For A Hat... 
 
Simple Forms 
After trying out some complex forms I thought it better to start with simple forms to get grip on this handy program.
So I started with a cube and tetraeder and that worked well.

My cylinder doesn't come out.
So I assured myself the points were on grid, used noesis to convert it again, as my *.obj files didn't seem right.

What I tried looks like a cylinder, but I needed the spikes method, otherwise there were some blended side patches and the form was not editable in quark.
Now it has the form but the patches are glued inwards. 
 
Maybe turn off "axis aligned" ... that will mess up a cylinder. 
Nope 
keep on ending on this result.
Here are the obj and map file.

I tried the email, but it's outdated. 
Location Outdated 
I would like to add some fine results,
but feel so lame by example. 
Madfox 
Your map file looks fine to me as far as the geometry goes. The cylinder is open at the ends so you can see the ugly spikes generated by the "spikes" method, that's normal.

Whose email is outdated btw?

For the texturing, try downloading the tool again from post #66, you have the older version; it should say "UV conversion beta 2" in the title bar. Your obj file has "usemtl UnKnown0", so you need a wad file in the same directory with a texture called "UnKnown0" for the UV import to work. 
Ericw 
I sended an email to warren.marshall/dot/epicgames/point/com.
That's the email adres on the linked site and it didn't work.
I saw there's another one in "people" so I guess it is altered.

I will try the updated one, maybe it has better results.
This one brings up a cylinder with triangles messed up to the inside.
I expected a smooth round outside.

thanks for the hint. 
 
I don't work at Epic Games anymore.

But regardless, any UV stuff is really Eric's ... I have NO idea what black magic he's doing. :) 
Warren 
JackJazz will miss you.
^v^ 
Doesnt Export On Extrusion 
Hey there,
I've been looking for something like this for quite a while for mapping with COD: WaW and COD 4, but I just cant get it to work the way I want. It seems "extrusion" is more than likely the mode I'd want to use (as I want to recreate a map from a 3D model. I've used OBJ exporter for 3DSmax 2015 which seems to have exported properly. I've removed all textures (as I don't mind re-texturing), so in OBJ2MAP i've typed caulk in place of DEFAULT so COD WaW Radiant will read it. Unfortunately due to the conversion process, it's just got too massive in scale, and there is no option to reduce scale on OBJ2MAP.
Any ideas ?
Thanks in advance. 
... 
I totally must have had a mans look. Just saw the "scale" % field. It still crashes at Extrusion though (Unhandled Exception). It makes me have to exit the program and re-load it, otherwise the log file is "in use" by another process. 
 
That's odd. Does "Spikes" crash as well? That might work for something modeled in Max as well.

Also, try checking or unchecked the 'axis aligned' box and see what happens. 
Crashes on Spikes as well. Tried both combinations (with and without axis aligned box) and it does the same thing. I wonder if its Windows 10 related...or maybe I need some Runtime files that you have and I don't.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at OBJ2MAP.XVector.Multiply(XVector _V, Double _Scalar)
at OBJ2MAP.MainForm.GoButton_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
______________________

All I'm getting when I get it to make a map (which takes bloody ages) is a bunch of jumbled (but joined) brushes which I can only manage to load into trenchbroom (although i'm trying to get it into COD Radiant. There is no pattern there, it's just a jumbled mess.

Radiant throws a fit and tells me it's missing a { no matter how many times I compile it.

I think maybe I'm just expecting too much from this..single models it will no doubt work, but a whole map is probably just too much for it to handle. 
 
How many faces is your model? I was able to convert a whole map's worth of geometry for terrain without problems from obj2map, so it might be something else. I used max 2009, possibly the obj format is a little different in 2015? 
Summary:
Vertices: 33410
Faces: 12
Brushes: 202

It is possible that the obj is getting corrupt in the conversion process I suppose, but I can load it perfectly into windows 10 3d builder and Blender. I can not get anything to export the .map's properly though. 
Jon 
Which build of obj2map was that with? Maybe try the beta in post 66; I remember fixing a bug with a similar stack trace as what you posted. 
Both versions (1 and 1.1.1) did the same thing. I'll try this beta (extrusion\grid align locked it up to a "not responding" state), so I'll try the other combinations and let you know 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2022 John Fitzgibbons. All posts are copyright their respective authors.