News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.

http://quakespasm.sourceforge.net/
First | Previous | Next | Last
Hmm... 
on the other hand, you can't install two different dm1.loc files in the same directory, so players will have to choose just one.

second, if one format is supported mostly by netquake engines, and quakespasm is a netquake engine, does it make more sense to support that one format? You'll be playing with teammates who are also using a netquake engine and therefore the "proquake" style .loc files. 
Loc Differences 
ProQuake locs are boxes. Quakeworld locs are points.

Quakeworld locs often give a wrong location because they don't know "what room you are in".

For example, let's say you are outside DM3 in the pent area, but standing near the wall close to the rocket launcher area --- if you go by point, you are probably nearer the rocket launcher. But not in that "room".

DarkPlaces supports both formats, although in the past LordHavoc stated once that he had a preference for the ProQuake version because it was more accurate.

/Mark V supports ProQuake .locs 
... 
For completeness: ProQuake locs link: http://quakeone.com/proquake/proquake-locs-frenzy.zip

I imagine the Quakeworld .locs pretty much come with ezQuake. 
 
Is there actually any benefit in using the 64 bit version? 
Sorry For The Doublepost 
Is there a way to get around display glitches like these? Or is it just imprecision in the construction?

https://dl.dropboxusercontent.com/u/15588722/post/func_msg/glitter.png 
Display Glitches 
ptoing, do these happen with gl_zfix set to 0 as well? 
 
Just checked, it was set to 1. Setting to 0 fixes this issue. Thanks :) 
Ptoing 
Thanks for confirming that. gl_zfix activates a workaround for the z-fighting (flickering textures) seen in some of the original id1 maps. It can however cause (minor) glitches such as these, so while having it default to "1" may best for the id1 maps, this is probably not true for custom maps... I'll discuss with the others. 
 
Yeah, I think I never noticed any of those flickers in the original id maps. But I distinctly remember finding some secrets in custom maps when it was set to 1. 
 
Try going to the quad secret elevator in e1m1 with gl_zfix turned off for a nice example of z-fighting (look at the elevator while it's still "in the floor" and look around a little). 
 
Oh yeah, I noticed that in Fitzquake. I guess that does not have the zfix thing? or maybe it is not on by default. 
Other Issues With Multiplayer 
Guys,

I have further issues with the QuakeSpasm OSX client and just cannot use it for multiplayer. I am now using GLProquake OSX which has sound issues but I'd rather have problems with sound than the sum of the issues I've outlined below with the QuakeSpasm client. For informational purposes, I'm on the latest Retina MacBook Pro and also Thunderbolt Display.

1) There is a great deal of negative acceleration at the bottom and top of the screen. This makes RJing impossible. If you bring your crosshair all the way down to your feet to make a rocket jump, your crosshair will spazz out and throw your aim all over the place. Without RJing, multiplayer is severely limited.

2) The timer is inaccurate. The timer doesn't start at 0:00 if someone starts a CRMOD match. It ticks up from wherever the map started. So essentially it's like not having a timer. If someone pauses the match, the timer also keeps ticking. The timer needs to be fixed for clan ring / match play.

3) The teamscores in the HUD are not added up. Therefore, there's no way of knowing how far up your team is in the game without manually stopping the game to do math. This is important because in a DM game, sometimes with 2 minutes barely up you want to hide. Generally speaking,all clients have had these teamscores added for a while, they should be there?

4) LOC support missing.


I really think if all of this were addressed that this would be the best OSX client but even the negative acceleration is too big of a problem to ignore. 
Omi 
Thanks for the issue reports.

Does negative acceleration happen with ioquake3? Specifically their prebuilt binaries from http://ioquake3.org/get-it/ (over 5 years old fwiw) use SDL1.2 like QS and the mouse handling code at first glance is basically identical to Quakespasm's.

Searching for "negative acceleration" a bit, the typical cause seems to be systems where the mouse cursor is centered in the window at the start of each frame, but if it moves fast enough to hit the edge of the window it just stops. If that's the cause of ours, there may be nothing we can do but see if they fixed it in SDL2 and bug the sdl devs about it.

Also if you could post a demo of what the spazz out when rocketjumping looks like, that would be sweet! 
Neg Acc 
Try playing with higher display resolution. If this helps, we are at least finding the cause of the problem.

http://www.doomworld.com/vb/source-ports/50224-mouse-in-sdl-ports-choco-ee-odamex-prboom/
And you know what? It is limited to the resolution:
for 320x200 it is [-160;159], for 800x600 it is [-400;399]
and so forth... So, if the mouse responsiveness (dpi) is high,
like logitech g5/g9, the game becomes unplayable,
unless you set hi-res, like 1600x1200+...
Bug appears when mouse cursor coords try to go over "screen limit" -
movement is just trimmed.
 
 
Being able to execute mods from within the engine is pretty cool. But I wondered if there is a way to also change the -hipnotic and -rogue switches from within the game, and perhaps also have another one to switch back to default id hud layout. 
 
Yeah, those could probably be cvars 
.. 
Mark V has a such a feature.

typing: "game warp -quoth" in console.
or "game metmon -quoth" etc. 
 
Add: a vanilla implementation is pretty easy to implement. In Mark V, I paired it up with the "game" command because the existence of "-hipnotic" or "-quoth" or "-roque" affects what pak files to load. 
 
Would be a great feature to have in QS as well :) 
 
The mark v implementation sounds like a good way to go 
Fitz 1.0. 
When? 
 
I've wondered when next FitzQuake will come out too. 
@ptoing 
FTE auto-detects the available elements in the gfx.wad file, and decides which hud to use based upon that. thus -hipnotic and -rogue arguments don't affect the hud by themselves. 
 
Spike man, it would be AWESOME if you nominated a version of FTE for a stable release, documented all of its current magical powers, and put it up on a webpage for the world to see. 
Spike 
Just tried to load a quoth map, and there it did not work. fteqw.exe is what I used, latest SVN trunk. Didn't load the proper HUD with the Plasma. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2022 John Fitzgibbons. All posts are copyright their respective authors.