News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.

http://quakespasm.sourceforge.net/
First | Previous | Next | Last
In Linux 
while true; do inotifywait --event open /home/me/games/quake/id1/maps/randommap.bsp && sleep 1 && file="$(ls -1 /home/me/games/quake/id1/maps/*.bsp | sort --random-sort | head -1)" && echo $file && ln --symbolic --force "${file}" /home/me/games/quake/id1/maps/randommap.bsp; done

This uses a symbolic link instead of copying the file every time. 
Hey This Is Fun! 
 
Map Randomizer In Qc For Barnak 
Open up your id1/maps folder...

Right click in empty space and choose on of the following: "Arrange icon's by" - size, date, alphabetically etc etc...

Close you eyes, NO peeking, this is important for it to work...

Raise your hand, forefinger pointed out, move it spiraling in towards the monitor...

Until it touches...

BAM, there's your random map generator ;)

You can restart at step one and choose a different option to keep it random too...

All done with "qc", short for quickly conceived!

Realize, eventually all dogs let go of the bone sooner or later. 
Meant Random Map Selector 
 
 
He already specified several times that it needs to work without leaving engine. And playing for my solution for a while I have to say, yeah, it absolutely does. 
Spirit, Correct Me If I'm Wrong But... 
Both of our methods are initiated before the engine is even started right? None of what you suggested works "in engine"? 
 
With "in engine" I meant that you can get a new map without leaving the engine/game. My script needs to be started before the engine but then it runs as long as you don't kill it. 
Gotcha ;) 
Can I run this in a terminal, and end by closing the terminal? 
 
exactly that, ctrl-c to stop. making it into a systemd service that launches on login would be easy too. I think the sleep is unnecessary (since the file was already opened and thus the link can be changed) but I am not entirely sure. 
Had To Install The "inotify-tools" But Worked Like A Charm Spirit :) 
You have to start a new level before the next "new" randommap.bsp symbolic link will work. Dropping to the console and "disconnect"'ing doesn't trigger it.

COOL! 
 
bind m "map randommap" worked fine for me in a some days old QS. 
All Of The Above Made Me Slightly More Happy 
 
 
Ah, of course, it needs an initial map. Sorry!

I made it into a script: https://www.quaddicted.com/forum/viewtopic.php?pid=1169#p1169

It's awesome to go through sm* maps. sm161 had some fantastic ones. 
Gamma Is Broken In Dev Builds 
I ran r976 and found that gamma adjustment doesnt work anymore.

System: Windows 8.1 Pro x64 / nVidia GTX 650 Ti card, 335.23 driver.

0.85.9 is working fine, but prints "vid_gamma_setgamma: failed on sdl_setgammaramp" error in the console when I change gamma value. 
 
Playing apsp1 (The Final Threat by than) I noticed that there is a kinda mangled lift right at the beginning.

https://dl.dropboxusercontent.com/u/15588722/post/func_msg/apsp1.png

It's the lift to which you get if you ride the lift you start on down and then just go straight ahead. There should be a pillar from the lift in the middle of that shaft (it's collision is there) but the lift seems offset to the right (from this view anyway).

Another thing I noticed is that impulse 12 does not work reliably. As in, in some maps it does, in some it does not. 
Pretty Sure That Lift 
is fucked in all engines, isn't it? 
 
impulse 12 is a mod thing, it was not in the original QuakeC sources so many mods don't come without it. The funtastic reQuiem engine has engine-side support for it in any mod!</spam> 
Apsp1 Has Same Prob On OS X 
I noticed the same problem as ptoing, on my Mac, with the latest QS.

I also noticed a similar prob on another map (don't rememer which one).

WTF !? There wasn't any problems with them before. 
 
I just checked the video of DaZ on the tubes of that map, and there it is fine. So it seems to be a newer thing. Having an option to force impulse 12 or maybe make it so that it is a different command weapon_prev or whatever, might be a good idea. 
 
Oh also, a small quibble I have with QS is that the console sometimes fucks off when you enter something right after you called it. Kinda weird. 
Gamma Again 
Tried same build on home PC - gamma working just fine.

System: Windows 8.1 x64 / nVidia GTX 770 card, 337.88 driver. 
 
@ptoing,
the apsp1 platform bug is discussed here: http://celephais.net/board/view_thread.php?id=60306&start=647

IIRC it's a map bug that only manifests with extended protocols like 666, and the cleanest solution is patching the map.

@AAS, thanks for the gamma bug report. Can you try this build? http://quakespasm.ericwa.com/job/quakespasm-ericwa/lastSuccessfulBuild/artifact/quakespasm/quakespasm-r2957b2fbabe632e603b0a86b45d23496a6af5845.zip

I set USE_GAMMA_RAMPS to 1 in that build. In r976 we are calling a different SDL function to set gamma than in 0.85.9, the build above should use the same function as 0.85.9. 
@Ptoing 
I assume you use german layout? And the character is this one ^ (circumflex?) showing up in the console?
This has already been reported, Eric had a fix at hand.
Iirc SDL 2.0 should get rid of this? 
Mfx 
I use a UK layout (hate the German one). And there is no special character showing up in the console, no. Not that I noticed. It happens whatever key you press.

Also, making the textures stuff I was wondering, would it be hard to implement something where you made animating textures with more than 10 frames if you would use for example a - instead of the +, but make it so that it is totally an engine thing. So you got both textures in the bsp file, but you use the + ones, and the engine will use the - ones if they are there. I reckon you'd need to fiddle them into your wad using texmex or something similar. Would be cool though to be able to have longer animations. 
Impulse 12 
impulse 12 is a mod thing, it was not in the original QuakeC sources so many mods don't come without it. The funtastic reQuiem engine has engine-side support for it in any mod!</spam>

Impulse 12 is not a mod thing. It is part of stock quake, but was added into a later version (eg: not 1.0; the quake we all play is 1.6).
If a mod doesn't have impulse 12, it's either because it's old and was made before the final 1.6 patch or the mod author used an older progs source as a base. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2022 John Fitzgibbons. All posts are copyright their respective authors.