News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
I am having a similar problem and have had no success either. Any update? 
No Prt File Found 
whenever i try to use vis.exe on my .bsp, it says "LoadPortals: couldn't read map_name.prt". It was running just fine a second ago, so what happened? 
or your directory is changed with the last qbsp compiling.
Compile again and see if there are no leaks. 
Player Precache Error 
I'm working on a project where I need to add some coop starts to a BSP that doesn't have them. I've been able to add other items no problem, but coop and dm starts give me a player model precache error.

Using this tool to insert the spawn points:

And the mod is progs_dump 3. But I'm sure we didn't change anything re: precaching of player models.

Testing in IW 0.7.0

I'll keep testing an perhaps try some other tools, but wondering if anyone had any ideas why this is happening. 
To be clear, I don't have the map source. 
I tried adding a trigger_teleport and destination using a bmodel hack and crashed with the same error. After successfully trying AdQuEdit it looks like this is an issue in the web tool linked above. 
Nope not the web tool. Copy and pasting entities from TrenchBroom was causing issues. I was using TB as a reference for the ents and occasionally pasting causes issues. Probably re-ordering entities in some way.

That Helps 
Textures In The 2D Viewport 
I have a separate project where I am trying to export a 2D view of my map without any distortion from the orthographic view. The top down 2D viewport view would be perfect for my needs but I am unable to find a way to display textures. Does anyone know of a solution for this. Even a different map viewer would work If it had 2D views. (the only messy solution I have found so far is to screenshot the 2D view and add textures later.) 
How Can I Make A Swinging Door In Trenchbroom ? 
Im new to modding and I want to make a gate door swing open on a trigger.

I have already made a mover entity rotate on a trigger, but the pivot point is in the center of the brush. How can I change the pivot point? or what would be a better way to do this ? 
You can't really make a swinging gate using unmodified Quake; your best bet is to develop for a mod like progs_dump, Alkaline, or Arcane Dimensions.

progs_dump would be the most straightforward to use if you haven't done much Quake mapping before, and it does add a bunch of rotation-related entities as you can see in its manual (there's a "Rotation Entities" section near the end). As well as a bunch of other tools and helpful things you may want.

There's a progs_dump thread with a download link and some discussion over here:

If you're going to develop for a mod like progs_dump, then in general you'll need to figure out how to configure TrenchBroom to target that mod, how to launch Quake to run your mod, etc. I think the progs_dump manual has some good info about how to set things up, also there's an (older) video about that here:

BTW I know on reddit some folks suggested you hit up the Quake Mapping Discord for live help, and that's a good idea for when you run into problems/questions. 
How To Set Default Values For Entities In TB? 
Every time setting "func_detail" to new brush(es) I need to add a key "_phong" and set a value "1".
Is there any way to set it as default and newly assigned func_detail brush obtain this key automatically?
Thank you. 
You need to edit the .FGD file 
It Is Not Hard To Edit Text File 
(I`m using ad_1_8.fgd by Sock) but need to know what exactly to do. There is no entities with predefined keys in it(?) that should be an example. There`s any tutorial for editing/creating entities definitions file? 
Ah, I thought you were using one of the basic FGDs so you were missing the key entirely. Looking at ad_1_8.fgd, it has the following definition for func_detail:

@SolidClass base(FuncLighting) = func_detail : "...

meaning that func_detail should take all the keys and values that are defined in FuncLighting group/class, which is defined earlier in the file:

//_____baseclass for BModel lighting options_____
@baseclass = FuncLighting [ ...

and this group/class has the following key defined, among many others:

_phong(choices) : "Phong Shading" : : "1 enables...

So with that .FGD, any func_detail brush should have tons of keys defined in FuncLighting appear in the Entity window in TB.

Or the issue is that you actually see the "_phong" key but it's a hassle to manually select "1 / Enabled" for every func_detail brush?

Then try setting a default value like so in FGD (added 1 (or try "1"), between two colons which have nothing between them in original file):

_phong(choices) : "Phong Shading" : 1 : "1 enables...

But it probably won't work the way you want - if I remember correctly TB won't include the key/value pair of an entity in the .MAP file unless it was manually set, I think. So it seems like these default values are there just for information. 
@ Gila 
Thank you for such a detailed answer! Really, ad_1_8.fgd by Dan Ellis & Bal & other has more keys already available in entities options window unlike Sock`s ad_1_8.def, wich I use. Editing .fgd does not give me the expected result so I probably just will use .fgd instead of .def 
Minor Errors While Compiling 
When I compile my map, I get the following warnings:

WARNING:[line 1566]: brush has multiple face contents (SOLID | MIRROR_INSIDE[false] vs WATER | MIRROR_INSIDE[false]), the former will be used.

WARNING: unable to find texture skip

WARNING: 62 sides not found (use -verbose to display)

I can play through my map without any issues, but are any of these warnings important? If so how would I go about fixing them? 
multiple face contents usually means you have a brush where some faces are water and some are solid, (or any other mismatch like lava vs water, solid vs. slime, etc.)

the skip texture error probably means your WAD file doesn't have a skip texture.

third error is unfamiliar to me. 
Ok, thank you for the help! 
Legacy Format To Valve 220 In Trench. 
Sigh... I was asking this in the TrenchBroom Git, but either I got banned or that github section was disbaneded =)

But doesn't it work to copy from the legacy map format to valve 220?

Also... trenchbroom should really have the newer format as default. 
I would be super surprised if anything like either of those things happened. Are you talking about some issue you created on GitHub?

FWIW, that sort of map-copying does work, and the newer format is the default. 
Haha, yea, that probably did not happen, just not sure why I get 404 when I want to go to that thread, I can't even get to the discussions page any more.

Yea, it was default, I was just in the generic game title. Could be default there too. 
1 post not shown on this page because it was spam
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.