News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
Thank You* 
i know the .lit files should be in the id1\maps folder, but they are not there, and my map does have light entities on it 
This is just a warning. This may be caused by planes that intersect at very acute angles. Check for "invisible walls" near the area specified. If you don't notice any problems it can usually be ignored. Making sure all vertexes are on a grid of 4 or larger might help. 
Have you done a search on your computer for your bsp's .lit file? Maybe it's been saved somewhere else for some reason. If not, maybe check your saving output paths? 
i've done that, all .lit files are from Hexen II, and i'm not mapping for Hexen.

Also, is there a tool like the necro's gui to compile maps, but for Quake II? 
Thanks for the info.

I think we may have found a way to fix and avoid getting the errors, as well as not scrapping the map, yay. 
Not sure what you mean by all .lit files are from Hexen II.

Necros' GUI is just an interface that uses external tools. Trenchbroom 2 supports Quake II mapping and has a built-in compiling interface. Its configuration is a little less n00b-friendly than Necros' but should work fine. 
.lit files are only created if you use colored lighting. There is no point in looking for these if your lights are all desat. 
A few questions:
Does light compile fine? No errors? Are you sure your light values are correct? When you launch the map, is everything pitch black or fullbright? 
Lit Creation 
Some light tools do generate .lit files even if there are no actual colored lights in the level!

However, a map with standard lighting (=no colors) does not need a .lit file as the normal lightmap data is baked into the .bsp file. 
light seems to compile fine, atleast there's no errors there. when i open the map is fullbright

so Necros's GUI supports Quake II? Because, i do know that Trenchbroom 2 has a compiling interface in it, the problem is that i never managed to get it working.
Also, what i mean is that all .lit files are from Hexen II, not Quake 
What happens when you type r_fullbright 0 in the console?

negke: interesting, I wasn't aware of that. I don't really see the purpose though. 
nothing happens 
so Necros's GUI supports Quake II?
I have no idea but if Q2 tools are similar to Q1 tools, I don't see why not. Like I said, it's just an interface that runs external programs.

what i mean is that all .lit files are from Hexen II
Yes, you've already said that. I suppose you mean that searching for .lits on your computer only returned results belonging in your Hexen II folder. 
Yes! Exactly, searching for .lit files resulted only in Hexen II files 
So I've been trying to make a button which causes part of the wall to move out to create steps so the player can walk up to an otherwise inaccessible area. I had some trouble getting it to work, and I think I did... but I have no idea why it works.

Basically the button is a regular func_button and the two steps are func_doors. My initial setup was to have the button trigger both doors, each of which has a different lip key (they are the same length in the direction that they move) so they form steps when opened. When I tested this, however, they both moved the same distance. Then I set it up so the button only targeted the bottom step, and the bottom func_door targeted the top one. When I tested *that* they didn't move at all.

My next plan was to return to the original trigget setup, give the func_doors the same lip key, and make the bottom func_door longer in the direction that it opens so it would extend father before reaching the "lip distance"... but before I tried that I went to fix some other things and just deleted all targets and targetnames associated with the top step so that only the bottom one was set up, leaving the top a normal func_door with no trigger setups... and *this* made it do exactly what I wanted it to do.

So why did my first attempts not work, but my third attempt (which was not even a real attempt) did? 
@lpowell Re: Steps 
Are your steps(func_door's) touching each other?

Try the "Don't Link" spawnflag under the "flags" tab(or wherever you set entity flags in your editor).

Should be good to go.

after one week i'm starting to build rooms.
my first room!

it's weird. i never made any type of art, but i can see pouring my creative energies in this way.

but the monsters don't get any ilumination when they step above the bars

i have a func_wall with skip textures because monster don't walk otherwise. i tried putting a regular brush with skip or clip textures and it didn't work.
but, in any case, that's not important in this room.

the problem is when models step above the bars they get rendered totally black. even when i move all the brushes to world 
Btw I Did This, All Was Fine. 
Create a func_button with "target = steps"

Create a func_door(s), your steps, with "targetname = steps"

^^^ steps need to be separately created as func_doors or they operate as one. You probably know that.

If your steps touch each other set the "Don't Link" spawnflag.

You have to set direction for the steps. In this basic setup without modifying any lip values the button will open the doors in which ever directions you set for a distance of their length minus 8 units.

Hope this helps.

Also, the button triggering one door and then that door triggering the next door... worked for me. 
I believe monsters(models) take their lighting form the "lowest" floor.

Meaning that, wherever the monster can walk(horizontally), all lighting needs to be consistent across 3D vertical space for the monster to be lit correctly.

I recently had this issue as well, it drove me crazy. 
@damage_inc, they are touching; I didn't know touching func_door brushes would "link," that's probably what's causing both the "correct" and "incorrect" behavior. I think I can puzzle out what is going on.

And now for an unrelated question, which texture WADs have some cool stained-glass windows? Aside from id, rogue, and knave. 
Off the top of my head, there's a large one in Chicosruin. 
Door Don't Link 
I set this off always. Most of the time it's not what you want.

Daikatana has some stained glass textures as does Wolfenstein (RTCW). 
Why Door that should be open after trigger_counter calls it, it opens when some other door opens near it? Don't link doesn't work, I tried all kinds of possible combinations and nothing. What should I do? (yes, I'm doing vanilla Quake map, no mods) 
Triple Check 
I know you just stated so but be sure that ALL func_doors near the issue have Don't Link checked. It could be just one side of a door that is the culprit.

Secondly, make sure there isn't a targetname on one of the func_doors that could be causing an issue. Triple check both sides of the doors just to be sure. (Assuming you have 2 sides to each door.) 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.