News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
Okay let's try a few things.

Search for your mapname.BSP and try and find it on your machine. Take note of where you found it.

Next make sure it's been placed in your maps directory under id1 folder. i.e. C:\quake\id1\maps

next, start quakespasm, bring down the console and type map <your map's name>

does it run? let us know. 
that's the problem, i can't find the .bsp, i don't even know if it is compiling correctly, i've looked in every folder present in the setup, but there's nothing there 
I know this seems like grasping at straws but if you are using NecrosGUI, completely remove it from your it ago and set it up again.

There could be some corruption or other snag that happened. I had this happen to me one time and I was completely puzzled until I did what I said. 
i did that, and it didn't helped... could it be something with the map instead? 
Try to create another map and attempt to compile to see if it appears in the output folder!

Also, if you never got this to work...verify you have permission to write to the folder. (Doubtful but you never know.) 
it still doesn't work. and i do have permision to the folder. 
You have your parameters set completely wrong. Look thru the trenchbroom help and copy whats there word for word. Thats all i did to get mine to compile. 
CutNodePortals Warnings 
*** WARNING 12: New portal was clipped away in CutNodePortals_r near (1692.690 -17.259 408.000)

Is this basically when two, or more, brushes that butt up against each other get off by the smallest amount(almost impossible to spot) that they aren't truly flush with each other?

This is in a large scale map with lots of rotation and shearing usage. Editor is J.A.C.K. 
i copied word by word, but at the end i get three errors, and the .bsp file doesn't appear 
copied again, exactly like it is in the picture, with
the correct .exe files of the compilers, but the same thing happens 
If you're trying to compile? Have you tried this program yet? 
yes i did try it, it didn't worked. 
Can you share your file? I will see if it has something problematic going on. Otherwise, you just need to write down right output / working folder paths. Output could be your quake/id1/maps folder, and I think working folder doesn't really matter? I just made new folder "working_folder" under id1/maps folder. I can only assume compile went fine, but you couldn't just play it?

No any errors on compile console? If you open your Quake.exe and open console, type "maps", scroll and try to find your map if it is there. Then just type "map yourmapname", and see whether or not your map starts. If not, then let us know what does the console says. 
Also Create New folder "Utils" under quake/ folder. Download and unzip these
To that folder. Open Settings and go preferences, set Tools folder path to that Utils folder.

Mark also that 'Run Quake' and Set Quake Engines path to your Quake.exe you're using, it can be for example Quakespasm.exe / darkplaces.exe etc. And try combiling again. 
it doesn't compile, the .bsp file isn't created. i have the compiling tools set up just fine too. and no, in Necros compiling GUI or whatever it's called, there's no errors messages. also, you want the map file, or the compiled file, because if it is the later, it doesn't exist 
Map file. There is email address on my profile page. 
no! nevermind, it compiled finally! thanks 
Glad it finally compiled. 
no!!!! nevermind, although it compiled, it doesn't have lights, they don't show up no matter what i do! although the first time i did it, it was alright, but then i had to change somethings, and now it the lights don't appear! 
Make sure Light is checked if using the GUI.

Check your output folder for a .lit file of your map's name. Delete, and re-compile and then see.

Keep at it and we will figure it all out. 
i am using the GUi, and the light is checked.

i can't find any .lit file in my quake folder though. 
The .lit files should be in your id1\maps folder, I think, alongside your .bsps 
...Or Whatever Folder Your Bsp Is In... 
Do you have Light entities on your map? 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.