News | Forum | People | FAQ | Links | Search | Register | Log in
QuakeDroid - Quake For Android
QuakeDroid is Android Quake that should run on any Android phone made in the last 5-6 years, but has only been tested on 2 phones (one 32-bit, one 64-bit).

Designed to have controls similar to popular mobile games (/cough Minecraft). Went deep on the documentation to try to empower the user.

Does not require Quake to install, it downloads Quake shareware on startup.

* How to put your TrenchBroom/J.A.C.K map on your phone
* Where is your Quake folder?
* Difference between shareware vs. registered Quake
* Put registered Quake pak1.pak from Steam/GOG on your phone
* How to set a startup command line.

The menu has 2 methods of navigation, you can touch items like "Single Player" or manually slide the volume slider bar or use the menu nav buttons.

* Tap-fire (double tap on an Ogre to shoot it)
* Drag-look (like Minecraft)
First | Previous | Next | Last
It's RAM. It is also asking for more RAM than it needs. I'll reduce the RAM it asks for in the next release which I am hoping for Sunday.

If you don't want to wait, you could alter the command line how to set command line just putting "-heapsize 256000" without the quotes in the quake_command_line.txt or if that still didn't work, putting "-heapsize 192000" 
I've tested on some retired phones. What info would be most helpful? Model numbers? Frame rates? Happy to take some time and collate data for you. They are mostly older Motorola phones but all shapes and sizes.

I horde all our older phones for some reason. 
Ah! Thanks dude! Had a feeling a simple command line would fix it but didn't know how to do access it. Heapsize 256000 worked like a charm.

Btw, are the controls setup set in stone? Reason why I ask is coz I played almost the entire Quake II campaign on my Android phone ( ) and those controls felt much better and extremely smooth compared to the ones you chose. I'm mostly referring to the movement + mouselook. Also, they were customizeable. Maybe something to look into!

Great port btw. Thanks for making it! 
I'll work on the controls until everyone here is satisfied. I'll check out the QII4A link you provided.

I knew going into this that the controls would be the #1 that needed refinement. The touch-driven menu that allows things like touch slider dragging was the hardest part.

Controls will take a few revisions to satisfy everyone.

@dumptruck - I'm satisfied with the feedback we have on existing devices, we have quite a range of feedback on devices. 
I Had Q4A On My Old Motorola Moto G 
But it stopped working when I updated from Android 4 to 5. likely it counts for Q2A and Q3A too. All made by the same guy. 
I see the weird lines in the water surface only when I am actually inside the water.

And using a bluetooth keyboard, lookspring and "centerview" (bound to a key) just stop working sometimes, then they start working again, then they stop working again.... I can't really tell under what circumstances they stop working or start working again. 
As you are a power user, you don't have +mlook/-mlook anywhere in your config or binds do you?

Without checking, I do not believe "centerview" works with mouselooking on.

Since mouselooking doesn't apply to QuakeDroid, I haven't considered the possible interaction between the controls and +mlook/-mlook.

If this doesn't have anything to do your setup, let me know ... I'm thinking aloud a bit.
On the other hand, lookspring was extensively tested. Should work anytime you start moving. Again, interaction with +mlook/-mlook has not been considered -- if that applies. 
@gunter - Force Centerview 
You might try a bind like "-mlook; force_centerview; +mlook" and see what happens.

I give centerview some thought. On a desktop, there is no way to improve centerview but on mobile there actually is because on mobile you know if a look operation is in progress because it requires a specific action to occur (which is a drag has started obviously). 
I haven't touched mlook. And I can't replicate the problem again, after Quakedroid crashed and I restarted it. If it happens again, I'll try the force_centerview 
Upcoming ... 
Delayed some due to adding game controller support, which proved to be a few steps harder than expected.

(Required SDL2 upgrade which happened to require an entirely different Android build system than the version I had been using (no fault of SDL2, Google changed the Android SDK/NDK) then discovering desktop SDL2 and Android SDL2 aren't really the same when it comes to game controllers -- so a series of experiments was required discovering differences until it worked.) 
Any Update? 
On when dual thumbstick style touch controls will be added? 
I'd like to try to have controls "right" by the end of this week. 
QuakeDroid With Gamepad Support 
Download: QuakeDroid w/Controller Support source: here

* Gamepad support (oGkspAz, Gunter asked for)
* Rare blue screen tint issue RGB565 (virto)
* RAM issue (brassbite)

Features the controller support implemented identically to Quakespasm, adapting the battle-tested controller code written by ericw (who supplied a reference on how to it efficiently).

This beta is to get the gamepad support out the door while a much more comprehensive update is in the making, hopefully out late this week.

Button names LTHUMB, RTHUMB, LSHOULDER, RSHOULDER, ABUTTON, BBUTTON, XBUTTON, YBUTTON, LTRIGGER, RTRIGGER. The DPad acts as arrow keys (and also supports diagonal movement), left stick moves, right stick looks (swappable). 
Glad to hear you got it working! I can test an Xbox 360 controller on my tablet later today. 
I would test this... but... my little Dell Venue 7 tablet has decided that it is dead now. :u

I shall have to acquire another Android device.

Also, you need to add that gamepad support into Mark V as well. 
@ericw, @gunter 
@ericw -- I ended up writing a short story about it on the SDL2 forums explaining how it behaves differently on Android vs. desktop, perhaps for the benefit of someone else using SDL2 on Android.

I'm approaching QuakeDroid from a "perfect prototype" mentality from a user perspective. Or at least trying to. I'm only human.

Butane provided a link to q2 android (qii4a) and I saw that the DPad worked with my controller so I wouldn't accept the DPad not working in QuakeDroid -- a small addition beyond what your existing code did.

@gunter - aw that sucks. Sorry to hear that :( 
Controller Would Make All The Difference. 
Hi guys,

I like this project a lot, and would love to get all my fav quake mods up and running on my android. But its damn near impossible to play without a controller.
I have a MOGA hero controller, is there any way this can qork with quakedroid? What to I have to do so set it up? 
Make sure you installed the special build a couple posts up.
Pair your bluetooth input device.
Go into Quakedroid
At this point I was able to use the DPad and LStick (A- and B-Buttons) for Menu Navigation.
Ingame the walk and look stick were working.
Then I went to options and to controller options and rebound all the necessary buttons.
My gamepad: Gamesir G3s, can recommend, really noice 
My setup:
R2: shoot
L2: jump
L1: last weapon
R1: next weapon
Had a blast playing, much more fun than touch. Don't get me wrong because I got along quite well with the touch controlls.

Sadly the Kindle still shows a white screen whilst playing the demo with sound. I'm looking forwards to the other graphics of Mark V coming to Quakedroid soon, or what I think I saw in the screenshot. :D 
"@gunter - aw that sucks. Sorry to hear that :( "

Heh, thanks.
Ya know, it really does suck! Hah, it's way more stressful than it should be when one of our little tech devices kills over.... But it served me well, daily, for the last 4 years. I think something in the hardware gave out, because factory resets do nothing.

In any case, I've found a nice little 7" RCA Voyager Pro Android 6 tablet on for just under $50. Gets high reviews. And comes with a nice little keyboard case and free 2-day shipping, so I should be back up and testing Quakedroid in a couple days. 
@apm - Thanks! Always nice to have more interested parties. Like brassbite said, should work.

@brassbite - I only added controller support in that beta but I think I'll do another incremental and throw that in plus, if I am fortunate, a 2nd with what you correctly saw in a screenshot :D

@gunter - Awesome! That's funny that it comes with a keyboard too for under $50. 
I didn't have any luck with my Xbox 360 wired controller. (no buttons/axes had any effect). Here is the qconsole.log:

It doesn't look like it was even detected as a joystick? 
Hmmm. Does it show as a bluetooth device in Settings->Bluetooth?

I suspect it is not showing as a joystick to SDL, but in the next incremental I'll add a warning for devices that cannot be opened (I can't entirely rule this out, I'll have it print unopenable devices in the next incremental).

I posted a code block @ insideqc code that shows what it does when considering a device. Note it always prints something and didn't for your XBox 360 controller.

I have the number of buttons check to exclude the accelerometer.

By the way, should you ever be interested in compiling, it is rather straightforward and I'd be happy to assist. 
GL QuakeDroid Beta - Fog, Alpha Textures, Mirrors, ... 
Download: GL QuakeDroid
Screenshots: Rubicon 2 Honey QMB Option

Suggested: if QuakeDroid has been loaded before ...

1) Settings->Video Options->Brightness: Texture Gamma
2) Settings->Preferences->Autoscale: Auto Large
3) (Option) If you want QMB particles Preferences->Effects: QMB

The above are new default settings but would be off in an existing config.cfg. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.