News | Forum | People | FAQ | Links | Search | Register | Log in
Quoth 2.2
Download | Map Packs | Changelog | Tutorial

Quoth version 2.2 is out! This is a spit-and-polish release, with some new features to play with, but the emphasis on refining the Quoth 2 content, re-balancing some monsters, fixing old bugs, and keeping Quoth as lightweight as possible.

The download links can be found above. There are two version: a full install of Quoth, and a patch that will upgrade 2.0 and 2.1 to 2.2. If you have 2.1, you will need to replace the existing pak2.pak file with the new one supplied.

Thanks to everyone who has tested and helped out to get this release together!
First | Previous | Next | Last
Kellbase1.bsp Bug? 
Just noticed this: load kellbase1.bsp, and noclip to the orange room with the water pool, just behind the info_player_start. Kill one of the pyro enforcers.

DP spams the console with: "WriteDest: Tried to write to non-client"
Fitz 0.85 and QS freeze for a second and then drop you at the console with this:
CALL2 596(WriteByte)()
: centerprint
: centerprint_toall
: counter_use
: SUB_UseTargets
: monster_death_use
: Killed
: T_Damage
: T_PlasmaTouch
WriteDest: not a client
Host_Error: Program error
Client ericw removed

This is on quoth 2.2. 
Replication Error 
Hi ericw. The log from the console tells me that the pyro is killed, the trigger_counter bumps the numbers, tries to broadcast the message to all players, picks an entity to broadcast to, and then crashes. The error is that the entity picked was not a player, and sending the message to a non-player is a no-no in Quake. However, there is already code which is meant to limit the messages to players, and I can't replicate the crash here with any of those engines.

If it's consistently replicable at your end, can you make a save game before you crash the game, and e-mail me that save game and your config.cfg/autoexec.cfg files, so I can see about fixing it. 
Sorted Out 
It turns out I was downloading which had an older (2014) pak2.pak than (2015).

Preach updated both the full and patch zips (thanks!), so you may want to download the patch if your pak2.pak is modified in 2014. 
Ooh, I didn't know that. I have the full version so I'd better check it out. 
No wonder I had so much trouble with the last jam. 
Umm, you mean map jam 7, I suppose? The last one runs in AD. 
Someone just told me that doing -game warpspasm -quoth doesn't play the startdemos.

I know this wasn't on purpose.

I wonder if there are any other standalone-like releases like The Living End or such that are also impacted.

I'm just raising awareness of the change of behavior.

/I will probably have Mark V block loading of Quoth 2.2 pak2.pak (just have it load up pak0 and pak1) for Warpspasm eventually, since you implemented a very organized structure for falling back to the previous version. 
The full zip on Preach's blog still has the pak2 file from 2014?! 
Not for me, I just dl'ed it again and the pak2.pak is modified nov 2016. The link on points to:

Maybe some kind of caching issue? 
This file on that page ...

Has a pak2.pak dated March 2015. 
Maybe is time for Quoth 2.3 since Quoth 2.2 can have so many different meanings. 
The March 2015 and Nov 2016 pak2.pak's are identical (just checked with 'diff').. so I guess March 2015 is the actual last modification date. 
I re-installed Quoth 2.2 last week, my pak2.pak is same as negke's (May 3 2014) from Quaddicted.

And if you look at this page, and the file dates for the pak files ... 
Point Releases 
There have been in effect two "point releases" of Quoth since 2014, each of which fixed one bug that occurred rarely but was troubling. They really should have been called 2.2.1 and 2.2.2 but it's too late now. Quaddicted has the original zip (2.2.0), the version on my site has the updated one (2.2.2). I think Quaddicted is the only major mirror of the mod, so if that can be updated then it should all be fine. 
When I go to download this file ...

Which ericw says has pak2.pak dated November 2016, like negke the contents say May 2014 for me.

So I open entirely different web browser than normal to make sure and download. Same problem. May 3, 2014 :(

Dumb question: As I understand it, Quaketastic doesn't let you delete or replace ... so can't be an internet caching issue (like what CloudFlare does) because same file couldn't have upload twice with same name? 
Replacement On Quaketastic 
As I understand it, Quaketastic doesn't let you delete or replace

It does, and that's what I did. Maybe your ISP has some kind of caching layer which is messing this up? 
Try which has a different filename so should circumvent those issues. 
Ok, you replaced it. That makes a great deal of sense then, very likely is network backbone-level caching. Which can be a real pain. 
I just downloaded the file and it's May 2014 still.

Probably should have a couple of other people other than myself check it out because I'd feel real bad if somehow it is just me.

Like negke since he reported the problem. 
(I did not click a wrong link, I assure you and I downloaded it twice). 
I just downloaded the link in post #65

Inside is a text file called quoth2_2.txt

Inside that is a legal notice including the date "May 2014" 
oh, but it does have a pak2.pak with a date of 11/11/2016 
Ok, just me. Ignore me. Important thing is problem solved.

Maybe caching works with a database that ignores punctuation and hashes the alphanumerics. 
Not Just You Baker 
Just downloaded it for the 1st time with the link in #65 and got pak2.pak, 8.0 MB from May 3rd 2014 @05:24

So this REALLY is the most recent file though? 
Have you extracted the file and checked if it displays the same modified date? Perhaps there's some glitch with the zip if you overwrite the file within a zip which puts the archive goes out of sync with the actual file - and that might cause the displayed date to be OS dependent.

Then again, maybe the OS dependency will also appear on the extracted file. Here are some file hashes to check for pak2.pak:
MD5: 69c2c4880ccb367cee1e338194d47184
SHA-1: e357e0b2b78703e2ebb32ab822911b77c4b0a37a 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2023 John Fitzgibbons. All posts are copyright their respective authors.