News | Forum | People | FAQ | Links | Search | Register | Log in
RemakeQuake Winter Demo 2011
Here's the d/l link: download
The RemakeQuake blog with screenshots: blog
And our public forum for feedback: forum

The pack consists of four large levels by myself and Ricky along with a load of new Qc, sound and engine features. Shortly we'll be releasing the tools version as well, which features the BSP2 tools. A small detail was omitted from the readme, that being the correct command line of:

-game rmqwinter11 -sndspeed 44100

Let us know what you think, this has been a long time in the making, but we're pretty pleased with the results.
First | Previous | Next | Last
That's Stuffcmd 
Moving liquid brushes use a stuffcmd of v_cshift to set the colour shift, but this persists until another such stuffcmd clears it. The same applies to stuffing fog, and any other such cvar.

You can see another effect of the same bug if you go to the green fog area in e3m3rq, save your game, exit Quake, then start again and reload.

Anything else using stuffcmd will suffer from similar.

It's something we're aware of but haven't yet found a robust solution for. Ideally some kind of "area flags" would be best, but that's going to really disrupt the file formats. 
just use non-saved vars for that.

nosave .float isCShiftReset

along with an
if (!self.isCShiftReset)

in a player think. 
There are a number of different ways of tackling it when you die/respawn. We could also stuff default values on respawn, or track changes made via stuffcmd engine-side.

The big problem is across the save/exit Quake/restart Quake/load boundary. The is visible too in other maps such as ne_tower, where r_wateralpha is stuffed after you shoot out the wooden boards at the start. Go halfway up the tower, save, exit, restart, load and go back down - water is now opaque again.

Right now I don't see a clean way of resolving this without format modifications.

Nahahra has a RestoreGame QC function which is used to re-stuff specific values that may be used in a map. That's quite a nasty way of doing it IMO (I'd prefer to see them as worldspawn entries) and it still doesn't deal with the case where values can dynamically change as you progress through a map.

Extending the save game system seems to be the only way (possibly by adding a state file so as to leave .sav files intact and usable in other engines) but I'm wary of the idea in case I've missed anything. 
Save Points 
Please read ....

Please! This save game crap must die.

Save games are for when you exit Quake and restart. Not for dying and respawning. Better concept in thread. 
My idea would only work for coop :( 
Somebody over at Q3World posted a link to a high resolution texture pack.

Maybe of help to your project as your are using stuff that size (1024x1024). Most of the texture are generic materials which could be useful for rock, concrete and brick etc. 
Multitexture Not Supported 
I get the above warning whenever I try to run the demo. I have never seen this before. Anyone know what it is, and how to fix it? 
Multitexture Not Supported 
What's your gfx card?

Also, there are two "Multitexture Not Supported" errors in the engine - "multitexture not supported (GetProcAddress failed)" and "multitexture not supported (extension not found)" - which of them do you get? 
Posted to the internal forum, thanks. 
Multitexture Not Supported (extension Not Found) 
I get this error too when I tried to run the engine alone (i.e. it's running OK when "-game rmqwinter11" has been added to its command line).

I deleted the config.cfg in id1 folder, and then it runs OK too. 
There's something incompatible in your config. It'll default to that config if there isn't one in the mod folder - you can place an empty one there (or one without whatever the offending line is) to avoid losing or moving your id1 config.

As to the cause - dunno.
Best bug ever. Make it official. 
I've no idea how a config setting could affect the ability to detect a GL extension. The only thing that would make any sense might be if you've specified a bad video mode for which OpenGL acceleration is unavailable (like maybe a 16-bit mode on some funky hardware that may hypothetically not accelerate 16-bit modes, although I've never seen that happen). 
Hahah - thats the magic system run amok. They're duplicating themselves and dimension dooring to your position. Skill 3?

If you build a test level with a vore in it try setting caster_level to 5+ and playing on NM.

They'll call in lightning from an empty sky, summon hordes and forcewall you.

Facewall is basically 'everything in this big circle gets gibbed' 
Yesterday I got the same vore duplication effect on e4m2. It was surprising - first I thought it just teleported near to me but it was sending copies after me. A bug I hope :) 
The code is unfinished, so buggy as well. 
Directq.exe - Unable To Locate Component 
The application has failed to start because d3dx9_43.dll was not found. Re-installing the application may fix this problem.

I got the above warning when I tried to run the engine with 'rmqwinter11' added. I don't use a custom .cfg. I'm not sure what kind of graphics card I have, my computer IQ is pretty low. 
DirectQ currently can't run this - you'll need to wait on the next version which will support it.

For that error you just need to update your DirectX to the latest version. (Having D3D10 or 11 isn't enough - D3D9 is completely separate and needs it's own update. Updating D3D9 won't affect your install of 10 or 11 if you have them.) 
Oh, And Mh... 
I have:

NVIDIA GeForce2 MX/MX 400

This computer is almost ten years old, so it's probably not cutting edge technology. 
Never gonna work.

DirectQ absolutely requires vertex and pixel shader support at D3D9 or better level. That means a GeForce FX or better. Even an Intel 915 chip will run it, but the shader support is required.

DirectQ is not going to be a good engine for RMQ for at least 6 months though - the devil is in the dynamic lights - it runs incredibly jerky and sluggish when they start going (and RMQ is full of them). 
Amazed by the cutscenes it took some time before I ended up in the little red room.
I shot the grunt and although the weak floor I couldn't get out, lost all my shells till I went ogre berseric with the chainsaw. Haha!

Started again, and was really excited by the topnotched map design. It took some time before I could identify the feeling of walking in a Q2 level with Q1 monsters.

I had to learn not to jump on ladders, and the large map environnement gave me a great fight with lots of enemies. I played on normal and didn't had the feeling they were perculiar strong.
The heat of the fight was more in the third part, after going up the elevator to the place with the two turrets.
I saved going up the elevetor, but died each time after reloading the level. I decided to save the level somewhat further, but kept on reloading the elevator.

Found one secret, and was amused the way the level developped. By its large format I had the idea of playing a sequence.
Not a bad idea, but to play the level it took me 90 minutes. (and didn't waist a minute of pleasure!)

Little things, like the gloom of the pent kept on the screen after reloading, a grunt frozen in its pose. Not things to mention.

Yes, a real warped Quake level! 
I finally played some of these maps as I downloaded this to play Tronyn's thing.

It's a useful demonstration of a lot of things Quake is NOT about:

OTT coloured lighting
Levels that looks just like Quake 2
Ice skating strafing monsters
Tinkly armour shards and health boosts
Massive glowing balls of light around laser shots
Floating footballs that shoot you
Off centre weapons
Changed sound effects to sound worse and more human or just bad
Horrible distracting screen blurring which hides how much damage you're actually taking
Enemy that are more like DM bots than monsters

There's a few things that Quake can be about in this:

More detailed ammo boxes
More detailed textures
Axe-wielding grunts
Hallways full of zombies waiting to rise and attack
Large stone slabs that grind out to form a bridge 
r_motionblur 0 
Massive Glowing Balls 
is that not the old gl_flashblend 0 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.