News | Forum | People | FAQ | Links | Search | Register | Log in
Direct3D 8 Porting Project
Baker and mh have been working on Direct3D 8 ports of popular Quake engines. The benefit of this is that people whose video cards have poor-quality OpenGL drivers can take advantage of better Direct3D drivers (many ATI and intel cards are in this boat, apparently.)

Engines ported so far:
* AguirRe's enhanced GLQuake
* Fitzquake
* FuhQuake
* JoeQuake
* TomazQuake
* ZQuake

More info and downloads: http://quakeone.com/mh/
First | Previous | Next | Last
 
The Hrim_sp1 lava platform is still broken under the new release. I can see the platform if I dived into lava using God mode, but it just doesn't come up when I press the button. 
 
Funny that because I just tried it earlier on today and it worked then. You're not running off a savegame made under the previous version are you? That might have messed up something in the entity if so. 
 
Started a new game and nocliped to the said area. 
 
And "said area" being here, right?

http://i56.tinypic.com/2uzfep3.jpg 
 
Yes, I nocliped to the area, pressed the button, and the platform didn't come up. I then did the same thing with Aguirre's and the platform worked.

Dunno why that platform is not working for me in directq.

My commandline is:

directq -nocdaudio -width 1366 -height 768 -conwidth 640 -conheight 384 -game Hrim +map hrim_sp1 -heapsize 54000 -id1 -bpp 32 -fullscreen 
 
It doesn't come up when you load the map from the command line. It does when you load it from the console. The very same happens with any engine that has rotating brush model support in the server code; so far I've traced it to one specific function in the world interaction; disabling the check for rotation fixes it.

I think this needs to go on I3D as it seems to be a bug in the rotation code that affects anybody who's using it.

Don't bother with -heapsize by the way, it does nothing. 
 
I know, it's just laziness from using Aguirre's and Fitzquake 
 
...and it also lets you swap out exe names without changing the params... ;)

More info: http://forums.inside3d.com/viewtopic.php?p=35089#35089 
 
What happened to host_framerate? How can I speed or slow down demo playback now? 
 
Does DirectQ by any chance support the playback of demos that were recorded with a level change?

I wish someone could modify BJP's convdem tool to support protocol 666 as well. And if it's just for joining demos (to fix the post-level change recording)... 
 
Please check if there is something wrong with Directq saving games, because I am only able to save one game. 
 
host_framerate had to go I'm afraid as it was interfering too much with other (normal) operation. I'll probably look into another way of providing functionality for demo speed up/slow down.

Haven't tested with demos recorded with a level change in some time, but unless I broke something recently they should work.

I've normally been saving from the console myself, but will test and fix if required. 
You Feature Scrapper!!! 
I meant non-DirectQ demos actually. And, alas, unsurprisingly they don't work. 
On Automap 
I loved the 3d wireframe descent automap, and it was a great tool once you got the hang of it. Just that descent's geometry complexity was a lot lower than quake's , I guess. The actual level geometry served well as a "bounding hull" that was visible in the automap.

Maybe you can figure out an algorithm that somehow makes large bounding boxes around level geometry while retaining the feeling of space, etc. you get from the base geometry itself. Then a 3d automap will be truly useful. 
Another Thing 
i think it's metroid prime where they show bounding boxes for rooms and then the actual geometry for the room you're currently looking at. Controls work much worse than descent's first person flycam though. 
 
i'd like to see an engine coder try to just do a rudimentary one with the bsp wireframe and just not display lines that are part of the coplanar face and restricted to the current PVS. (or the engine could do some expensive but one shot calculations to determine visibility with raytracing).
i don't know the math involved with that kind of thing though. maybe it's very complicated and weird or something... math usually is. ���_� 
 
Hi mh, can you check the map neh2m5, there seems to be a fish stuck in the ground where the four jaggers are in the beginning. This fish didn't seem to be there in Aguirre's. 
 
Checked it out, it's OK in the current version of the code. 
 
What's the command to turn off the colored muzzleflash again? All I found was r_colored which disables all colored lighting altogether.
I guess it should be in the advanced visuals menu, too. (colored lighting: full, only world, off).

Some time ago I had some trouble getting (a cfgless) DirectQ to run on Win7 without additional effort, because it was always using 1600*900 as default video mode which out-of-range'd my monitor. However, today it started in 800*600, so no idea.

I wanted to watch the latest SDA demos with DirectQ for easier file selection, but the engine crashed each time a demo ended. 
 
What's the command to turn off the colored muzzleflash again? All I found was r_colored which disables all colored lighting altogether.

Hmm, think that one got lost some time ago. Must add it back.

I wanted to watch the latest SDA demos with DirectQ for easier file selection, but the engine crashed each time a demo ended.

Something in the demo file it doesn't like is the most likely explanation. I'll download some of them and check it out. 
 
disconnect does't actually clear the intermission screen state in Quake. That's a new one.

So if you're doing anything with cl.worldmodel during an intermission you should set cl.intermission = 0 in your CL_Disconnect_f. Probably not a bad idea to do it anyway. 
1.8.8.test2 (and Earlier) 
The sound looping on moving func entities seems broken. It plays the sound once and then often just stops. I recall a similar issue in DP once. 
Some Directq Bugs 
I've been playing around with directq lately and I'm impressed with it. A convenient engine that seems to have (almost) everything I need nowadays, and that's also being actively maintained.

Is this the place to report bugs?

I finally played "masque of the red death" and I experienced an annoying problem. Entering a room in the middle of the map, it suddenly seemed like the floor started to behave badly. I couldn't ascend even the most moderate of stairs without sliding down and taking fall damage. Got stuck in architecture at one time. Seems like the "clipping" had shifted up or down or something, compared to the actual map architecture.

I flew around in noclip and made some save games. Restarted directq and the problem was gone. Also the save games don't display the problem anymore unfortunately.

My computer has an Athlon II X4 640 CPU, 8 GB of some RAM, and a GeForce GTS 450. Nothing is clocked above nominal rating. Using DirectQ 1.8.8 Patch 2. 
Ah, The Dreaded Clipnodes Bug 
I'd thought that one should be fixed, but obviously not. I'll need to pass over the code before the next release then.

It's useful to know some circumstances it does and doesn't happen in; that'll help a lot with troubleshooting. 
Savegames 
Here are two savegames, which when loaded now unfortunately no longer display the problem: http://mandelmassa.net/temp/masque.zip

I entered that room, and bam - stuff got weird. As far as I remember, anyway.

The second save displays an interesting bullet hole decal floating in mid air, though I don't know if it's strictly related to the clipnodes problem! 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2021 John Fitzgibbons. All posts are copyright their respective authors.