News | Forum | People | FAQ | Links | Search | Register | Log in
QuakeDroid - Quake For Android
QuakeDroid is Android Quake that should run on any Android phone made in the last 5-6 years, but has only been tested on 2 phones (one 32-bit, one 64-bit).

http://quakeone.com/quakedroid

Designed to have controls similar to popular mobile games (/cough Minecraft). Went deep on the documentation to try to empower the user.

Does not require Quake to install, it downloads Quake shareware on startup.

* How to put your TrenchBroom/J.A.C.K map on your phone
* Where is your Quake folder?
* Difference between shareware vs. registered Quake
* Put registered Quake pak1.pak from Steam/GOG on your phone
* How to set a startup command line.

The menu has 2 methods of navigation, you can touch items like "Single Player" or manually slide the volume slider bar or use the menu nav buttons.

* Tap-fire (double tap on an Ogre to shoot it)
* Drag-look (like Minecraft)
First | Previous | Next | Last
@gunter 
I'm considering some of those kinds of concepts. I feel if I can just get the controls more tuned ... 
Any Possibility For Alpha Texture Support? 
AD works great aside from that 
@bloodshot 
I have something in the works ;-) Might take a few days or perhaps I'll be very lucky and it could go faster. 
QuakeDroid Updated 
New Version :Just Reinstall
(Will show 1.92 in console)

New:

* Switched attack + change weapon position (everyone)
* Sepulcher support (pulsar)
* Underscore shows in on-screen keyboard (qmaster)
* Bluetooth keyboard use auto-hides in-game controls (gunter)
* Empty quake_command_line.txt doesn't hang. (qmaster)
* Water alpha vertical lines fixed (qmaster)

Looked into
* Immersive mode - Not seeing clear-cut SDL2 support in a stable SDL2 release. But will keep and eye on it.

Other issues/suggestions pointed out are on the list, I hope to get some more done in a new version in a few days.

Thanks for the feedback/suggestions/bug reports, Android is diverse in device variety and it has been greatly helpful! 
 
Hm, the onscreen control overlay doesn't seem to go away when I use my bluetooth keyboard(s). The overlay does vanish when I'm using messagemode though.


Change
Jump
Attack

is not a good layout. Your default finger position is on Attack. Other buttons should be within one button of that finger position. With Attack all the way at the bottom, it's a large motion to get all the way up to that Change button. That's why I think it should be:

Jump
Attack
Change


With thumb resting on or over the Attack button, it's easy to get to either Jump or Change.


So, it seems many mini bluetooth keyboards (like mine) have no Escape key. I can bind some other key to togglemenu, but it doesn't work like Escape, in that it won't cancel messagemode, for example. Luckily you have the little top-left triangle that acts just like an Escape key.

My little bluetooth keyboard has tougher problem though. Pressing Func+Up or Func+Down should give me PageUp or PageDown. But this keyboard is some weird generic thing (I have a different one that does work correctly in this regard), and instead it triggers Windows+Up and Windows+Down, so I can't scroll up and down in the console. So how about allowing me to swipe up and down in the console? A tap on the console should obviously trigger the onscreen keyboard, buy an up or down swipe could instead trigger PageUp/PageDown to scroll the console.


I also have a almost full-size Mircosoft bluetooth keyboard, and while it does have an Escape key, it doesn't even have Functionable PageUp/PageDown, yet it has Functionable Home/End.... So no console scrolling with this onn either. Though if I were going to use a large keyboard, I may as well just use my XP Netbook, heh. 
 
Looks like I needed to provide more detail.

Do you have a tidle/backquote key? That will trigger the console and cause the keyboard to hide.

Let me know.

Working on game controls come takes time, I did not have time to do anything with control. 
 
Oh, maybe we are talking about a different thing.

I had suggested that the onscreen control overlay be completely hidden in-game if a keyboard is being used.

Yeah, I can effectively use the tilde key and pull down the console -- the onscreen overlay doesn't show on top of that.

I'm wanting a way to hide the overlay during game play. Like if input is being detected, but no screen touches are being detected, that should indicate that someone is not using the touch screen controls, so the overlay can be hidden. 
 
Yeah, probably so but that thought didn't cross my mind at the time, haha.

So for now, press tilde and it will hide the touch controls. ESC to the menu will cause them to reappear.

Next time, I'll have any keypress hide the controls. 
Bugsmashing Feedback 
Underscore on console touch keyboard works great!
Empty command line file fix confirmed. (I like to keep it empty for vanilla.)

BUT water alpha no longer works. I tried different values of r_wateralpha but no luck.

Bug report:
When the player camera is looking too far up or too far down past about +/- 80 deg, the turn direction flips and rotates the view the opposite way. Expected:slide thumb right looks right, slide thumb left looks left. The wierd part is that it only seems to happen if I make one continuous thumb swipe that looks up/down and to the side in a sweeping thumb arc such that the view moves past a certain threshhold angle for pitch and only then does the yaw reverse. If I make quick single swipes it works correctly regardless of view pitch. 
Galaxy S9 
Very excited for this, but when I run it I get a blue screen tint to the screen as the opening demo plays. I can't access any menus at that point so the demo keeps playing with a blue tint to everything. I am testing with a Galaxy S9- any ideas? Thanks and congrats to Baker. 
@Virto 
Just to clarify: Can you open the menu? There's a small triangle on the upper left side of the screen that opens the menu.

@Baker

One other control suggestion to think about: Double-tap forward to jump. I think this would be a very elegant option. When I release forward I still have a tiny bit of momentum. That gives me a little time to jump by double tapping. Even if you use the radial / virtual joystick control scheme I think this would work. Would eliminate the need for 3 buttons on the left side of screen. 
Dang! 
Meant to type "eliminate the need for 3 buttons of the right side of the screen down to 2" 
@Virto 
That's unfortunate. This was tested on a Galaxy Prime (64-bit) before release.

My only ideas are reboot the phone, make sure you aren't out of storage -- but that is probably not much help.

Sorry that it isn't working on your phone. 
@qmaster 
re: water alpha ... are you sure? Type r_novis 1 in the console.

The looking down beyond your feet -- you can't look down more than all the ways nor can you look up more than all the way. That kind of behavior is baked into Quake on client side, server and input side. I know what you mean though.

@dumptruck - I'll be getting around to controls. The double tap to jump for instance sounds right. 
@virto 
I don't know that this would help, but I think what I will do is make it so any tap opens the menu during the start demos.

I'm not sure that this will help with what you described.

I'll be doing another update in a few days. 
Blue Screen Tint 
I've seen something similar mentioned in the SDL bug tracker/forums, = not sure if it's relevant:
https://bugzilla.libsdl.org/show_bug.cgi?id=2291
https://discourse.libsdl.org/t/android-device-displays-everything-in-purple-tones/21237 
 
Wierd, wateralpha is working now.

Looking up/down: the issue occurs before the pitch ever reaches full 90/-90. It is a matter of swipe right/left during up/down inverting once the pitch changes around 80 or so during the same swipe. Inverting = swipe left to look left actually stops turning left and starts turning right within the same continued touch if you look far enough up or down within that same continued touch.

Bug report: if a console command fails, e.g. map not found, the full screen console no longer registers the touch and does not bring up the touch keyboard. You have to start a new game before the console registers touch again. 
@ericw, @qmaster 
@ericw - Thanks for the link. According to that, it seems to imply that specifying the color format RGBA 565 might solve virto's tint problem.

SDL_GL_SetAttribute(SDL_GL_RED_SIZE, 5);
SDL_GL_SetAttribute(SDL_GL_GREEN_SIZE, 6);
SDL_GL_SetAttribute(SDL_GL_BLUE_SIZE, 5);


@qmaster - Another great catch -- yeah, I'll check to make sure console forced up allows access to the on-screen keyboard in the next version. Quake thinks it is in the game, but it isn't. 
@Virto - Special Build For You Try 
QuakeDroid Virto Blue Screen Fix Attempt

If it works, ericw is your hero!

I attempted to locate matches to the symptoms of your problem but never would have found that link. 
Blue Screen Fix Worked! 
Just tried it- works perfectly now! Great work! 
@virto 
Great! Glad to hear it! We're batting 1000% again.

My greatest fear on release was the diversity of the Android platform from models to Android versions to processors.

/Mega-thanks to ericw! It could have been weeks before I came across that kind of information! 
Sepulchre Support? 
I suppose your support implementation differs than Quakespasms, because I still can't play aristical's map in dm4jam because it is greater than 80000 verts. I haven't actually tested AD itself yet though. 
 
I didn't go full dynamic. I want to see if a minimal skinny implementation worked first. I'll go full dynamic next version so there is effectively no cap. 
@qmaster 
Neither Mark V nor QuakeDroid can load Artisitical's map. We even put a "this map requires Quakespasm" warning in the dm4jam start menu before the teleporter to this level. 
I Know 
I just wanted to test it after Baker added sepulchre support to QuakeDroid, something MarkV doesn't have yet either.

I'm trying to get my Gunter badge for the month ;) 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.