News | Forum | People | FAQ | Links | Search | Register | Log in
QuakeDroid - Quake For Android
QuakeDroid is Android Quake that should run on any Android phone made in the last 5-6 years, but has only been tested on 2 phones (one 32-bit, one 64-bit).

http://quakeone.com/quakedroid

Designed to have controls similar to popular mobile games (/cough Minecraft). Went deep on the documentation to try to empower the user.

Does not require Quake to install, it downloads Quake shareware on startup.

* How to put your TrenchBroom/J.A.C.K map on your phone
* Where is your Quake folder?
* Difference between shareware vs. registered Quake
* Put registered Quake pak1.pak from Steam/GOG on your phone
* How to set a startup command line.

The menu has 2 methods of navigation, you can touch items like "Single Player" or manually slide the volume slider bar or use the menu nav buttons.

* Tap-fire (double tap on an Ogre to shoot it)
* Drag-look (like Minecraft)
First | Previous | Next | Last
Bug Report V2.0 
Just downloaded the new version this morning and reinstalled. It did update as the console now has an underscore.
I am still getting the lines on transparent water mentioned in posts #60 and #85.

Samsung J5 Prime still running Android 6.01 
Congrats On The Release! 
On my phone, the Huawei P9 lite Quakedroid works perfectly fine.
I wondered if my Kindle Fire HD tablet from 2012 could handle Quake, and the shareware downloaded perfectly fine, then it just got stuck on a white screen. Don't really bother about, only maybe. I bet you can find issues more important, I bet it will lag the hell out of the Kindle (1.2 Ghz Dual-Core, 1GB of total RAM) 
@brassbite 
I'm glad it works well on your phone!

should run on any Android phone made in the last 5-6 years

For the 2012 Kindle, it might not have enough RAM or might be out of storage space. It could also be that the version of Android is too old. Also it is my understanding that Amazon rolled their own (outdated) Android especially on older Kindle Fire tablets.

Thanks for letting me know about the 2012 Kindle Fire. I think I know someone with one of those sitting around and I might be able to get ahold of it in a few weeks (at a minimum to satisfy my curiosity to see if I can get it to run).

You might be able to free up some space on it and still get it to work. 
I'm Fine On Storage 
Got at least 10GB of free space. Of the 1Gb RAM, it should still have 400 Mb free. Maybe. Just guessing, cause Amazon patched out the task-view. I can run a N64 Emulator though 
@brassbite 
Yeah, sounds like you are fine on storage. My Android phone, storage is more of an issue (4 GB) and during testing I managed to run myself out of space a few times.

If you posted Quakeid1qconsole.log off your device folder pic via USB, I might be able to learn something useful about the crash.

(You usually need to restart the device first to see the file. Android uses MediaStore to keep track of files and rescans on boot, Quake doesn't have a good way to update MediaStore because it is a low-level native C application.)

1) You might try the APK for Virto I made in post #100 to see if that works. It tells the device the desired color format.

2) Seems from your description that video works (download flashes the screen, changing the shading as it downloads) and that download works.

Barring that, I have a friend of friend who I know had a 2012 Kindle Fire, but it won't be quick to get ahold of it. 
@oGkspAz 
I'll have to play around. I'm hoping it isn't "luck of draw" depending on screen resolution. I modified the algo but apparently on some resolutions the draw stretches favoring certain columns more of liney look on the transparent water. 
@Baker 
I am pretty sure I have a 2012 Fire. Will confirm with you. This project is so cool I want to help out where possible. I can also test on other models. I have access to a Pixel and a 1st and 2nd gen Moto X. I'll report back. 
@dumptruck 
Could you check if your 2012 Fire has the problems that brassbite does? 
@Baker 
Yep. Will report back this evening. 
I Have An Old Fire Too 
Can't revall the year, 2013 maybe 2012. 
@Baker 
Unfortunately, my Kindle is from 2011 and gave the error: There is a problem parsing the package. Most likely the OS is way too old.

My wife has a much newer model. I will steal it and report back if I have any luck. 
Have A Log File 
And Another One 
This time I installed virto's build and got the same error

https://www.dropbox.com/sh/9aeb5venswilb5s/AADJilNeYdXCv10HXDbojgOMa?dl=0 
@brassbite 
Looking at the log, it appears the engine thinks everything loaded ok and it proceeds to start playing the demo.

Does it make sound in the background and just show a white screen while doing it?

Either way, I'll try to eventually get my hands on a 2012 Kindle Fire from a friend I know, just to satisfy my curiosity and see if I can get it to work. 
Suggestion 
@Baker fantastic job, but would it be possible in the next release to rise The step left / right icons at the same level of the fwd icon. In my opinion this would lead to an increased playability. What do you think? 
@brassbite 
I'm about 80% I know what's up with your Kindle and can fix it if it is playing the sound. I saw something in the log you posted that made me think.

@icaro - Thanks! I tried to make it very nice. Yeah, the controls need some tuning and it'll come. I've got a little bit of a queue at the moment. 
 
ICARO is right about the position of the move icons -- at least util a better control option comes along.

But while we're still using the current setup, I'll also mention, in addition to my previous preference for:

Jump
Attack
Change

that the buttons along the right could be positioned like:

. . . . . . Jump
Change Attack


with the buttons grouped around the bottom right corner. That still puts all buttons close to the Attack button for easy access. 
Seconded 
 
Sorry, I'm A F K Until Friday Afternoon 
Away from Kindle

Have fun with other issues meanwhile 
Lol, Guess That Meams I'm AFK Too Until Saturday 
 
Feature Request 
When touching the hud bar at the bottom of the screen, still let the camera move with continuously held thumb swipe.

Have you been able to reproduce the camera reversing effect? 
 
@qmaster - I know what you mean about the "camera reversing", I haven't developed a plan to properly "clip the drag look" if someone attempts to look beyond where Quake will let them. And other one will be a yes. 
Hey, Baker! 
Good News! It's only a drawing bug! When I turned up the volume, I heard the familiar sounds of Romero blowing up the Zombies... 
@brassbite 
Great! That's why I mentioned if it was playing sound.

The reason it is rendering white is your Kindle doesn't have an OpenGL extension allowing non-power of 2 textures.

When I had checked the source, I found I had commented out a couple of lines of code I wrote in the video section upsizing to a power of a 2 size. 
Doesn't Work On My Phone 
I'm getting the error: 'Not enough memory free; check disk space' but I have almost 2GB of free device space on the phone. It's a Galaxy Note 3.

Anyone have any ideas? I'm mot very good at reading code but that error message comes from here: https://github.com/ericwa/Quakespasm/blob/master/quakespasm/Quake/main_sdl.c

Could this be related to RAM instead? The phone only has 1GB of memory. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.