News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage:

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

First | Previous | Next | Last
disable autorun:
why would you? :o
cl_forwardspeed 200; cl_backspeed 200; cl_sidespeed 350; cl_upspeed 200; cl_movespeedkey 2.0; cfg_save

only way I can think of that happening is if you've bound shift+mwheelup to something different from mwheelup (fte understands modifiers). rebinding mwheelup-without-modifiers should also rebind all its modifiers too.

I really need to get around to editing those packages so that they don't conflict with other stuff.
If you've manually installed that stuff for use in eg DP, then you'll already have all that content anyway.

these don't get tested as often as they need. so are unfortunately often buggy.
I've only got an nvidia gpu to test vulkan on, and it generally performs worse than opengl. yes it has better cpu usage but it really sucks (for me) in terms of pixel fill rates compared to opengl or d3d. FTE's implementation is mostly complete - read: has more ways to go wrong.
d3d11: windows only junk... plus you're generally better off with d3d9 (the lack of custom hlsl means d3d9's support for oldskool multitexture gives d3d9 the advantage).
ultimately my time is limited and I'm lazy, and focus+test opengl the vast majority of the time. they should normally all be able to run vanilla quake well enough though, so if they can't then that's a bit of a fuckup, but as the opengl renderer still works it doesn't seem that significant.

changing content shouldn't change presets...
remember to use either the menu to quit or to use the cfg_save command if you actually want your config to be saved after changing/reverting any cvar/preset settings.

underwater sounds:
that's your openal implementation for some reason completely ignoring distances when reverb is enabled.
you can set s_al_use_reverb 0, or switch to some other driver/device via the menus (especially if you want something more quakey).

particles menu:
the particles menu is just a list of particle config files to use (the order in which you enable them can make a difference).
do note that particle configs are still configs, and there's a few evil ones that include non-partcle commands (like cvar settings) which don't get forgotten when unloaded, but a properly made effect (one that doesn't have such things) will be fully purged by just changing options.

the 'fast' preset hides static models (like torches+flames - quakeworld users tend to not like scenary), but the others should still include them.
the QRP models have no flame animation and expect that effect to be provided by a particle effect, which is a separate thing from the model. Yeah, its messy. :(

they're meant to be handled in pretty much the same way, except for editing. note that you might have different .rtlight files installed for the two engines.
if you installed the plugins/ingame-map-editor option via the downloads menu, you can then set ca_show 1, and you'll get some csqc-based editing menu. Be sure to pick the rtlights option... 
Replies And A Couple Of Other Things I Forgot To Mention 
- Well, as a single player, sometimes I like to take it slow and calmly appreciate the level's architecture, and seeing Quakeguy running with each movement sure makes it less of a relaxing experience. Yeah, I'm weird like that. But slower movement does provide some accuracy to platforming sections for example. So yeah, the slower speeds do have their use cases in single player.

- According to more testing the mousewheel weapon cycling starts working when I reconfigure the weaponcycle keys at the keys menu (even if according to the menu the mousewheel was already assigned to it). So, I save my settings, shutdown FTE and restart the game and then try weaponcycling again while holding down shift and the problem returns. So now it looks like that in addition to having to set the realtime lighting presets each time Afterquake configs are enabled in the "updates+packages" menu, now I have to reconfigure the mousewheel, too, every time I restart the program. Extremely frustrating. :(

And to make things even weirder, when I have the Afterquake configs disabled and then save my new weaponcycle bindings (and left shift key binding for the run action) and restart the program, the key bindings have not been saved. Does this have something to do with Windows 10 or system locales or something? Just throwing hunches in the air here.

- I got the underwater sounds working (ie. sounding like I weren't underwater at all) by changing my sound device from default to DS (I presume Directsound). I'm assuming OAL (openal?) was the default audio device. There was also a third device, WASAPI (no idea what that is), but sound was just garbled when using that.

-About the torches: I guess I can only hope someone makes particle effects for the torches with wooden stems at some point, then. (Or then make them myself!) @~@

- Here's a side-by-side comparison of how DP and FTE handle an individual ceiling light in one of my maps. In DP it's a nice subtle gentle light whereas in FTE it's a bright blue patch. (Note that the light radius of 0 is a rounding error from 0.01). Maybe my outlandish values like coronasize 3000 cause problems in FTE?

- A thing I didn't mention in my previous post is that sometimes when I startup the game (OpenGL and realtime lighting) I get models resembling Christmas ligths.

- Another thing I forgot to mention is that cursor keys are only partially supported in the menus. I think only in the main menu you can move up and down between the different options but in the other menus you can only use the right and left keys to adjust sliders. Otherwise I have to use mouse to switch between rows. 
Particle effect for torch and big fire is available.

Here movie shows a torch effect.

Me think you can copy effect. 
- runspeeds
yeah, sorry, I was just trying to be humerous, and failing. imho its better to set cl_speedkey 0.5 and otherwise with always-run on. if you need the precision then you can hit +speed (for slow), and then you're not required to hold a separate key every single time you encounter a vore etc. but yeah, not 'failthful' or something.
the afterquake menuqc stuff lacks an autorun setting because its not a trivial setting (so wasn't in the first versions), and then got overlooked once the code became more capable.
the engine's built-in menus do still retain the option.

- menu cursor keys
yeah, those menus were written as mouse-first menus.
any menu that might need a scrollbar (when running at lower resolutions / bigger fonts) has multiple tiers of widgets (ie: title+options[option1+option2], and the up/down arrow keys don't propagate properly between tiers - if the upper tier has focus then you can't change between the actual options.
You can disable the replacement menus in the updates menu, if this annoys you.

- binds not saving
fte attempts to sandbox its configs.
if one of the known-configs changes when switching gamedirs then configs will be reloaded.
when saving the config, that config will be saved to the active gamedir if the gamedir contains one of those known-configs and to id1 otherwise.
this means that a mod with its own settings won't propagate any of those settings back to the base game.
basically what I'm saying is that I'm not really sure what's going wrong here.

- sounds
wasapi is what directsound is a wrapper around (since vista). it generally has lower latency (especially if you tweak some cvars to request exclusive access to the hardware). I'm not sure why it'd be garbled, maybe I'm not feeding it enough data (try increasing wasapi_buffersize?). either way, its main thing is that there's a wasapi_exclusive cvar that can be set to 1. :)
otherwise it doesn't really make much difference.

- torches
I thought the hazed particles had something in them. the 'spikeset' ones do, but mneh.

- coronas
the general recommendation is not to hack the radius to some low value and compensate with an extreme corona size, but rather to set the corona scale to 1, set the ambient+diffuse+specular values to 0, and then set radius to directly control the size of the corona. must less hacky that way.
try setting r_coronas 0.25 instead of 1.

- lights
looks more like your r_shadow_realtime_world_lightmaps setting is different in the two engines. FTE has a habit of forcing it to 1 when it couldn't load/import any rtlights (too many buggy maps otherwise), but I've no idea why that could be happening in this case.
when comparing lights, it can help to disable bloom and any iris adaptation stuff (read: hdr), and srgb stuff too. this should make the colours more directly comparable.

- christmas zombies...
... I really have no idea...
does the mod that you're running mess around with .colormod or something? I have no idea why those zombies would each glow/bloom a different colour, unless your mod was using that.
are they still bright colours with bloom disabled?
does r_fb_models 0 help? 
FTE + Arcane Dimensions Mod 
hello, after a long hiatus i am back in quake realms and i have one question. i use darkplaces usually but i am testing FTE right now because DP cant handle forgotten sepulcher.

FTE runs that level fine, everything works - monsters, breakables, extra particle effect. All that works properly but when i get killed and load previous save new particle effects no longer look the way the should. i am talking about torches, power ups and so on... original ad version of these effects is replaced by something ugly. the only way to restore particles is to start level from scratch.

any idea what causes this bug? FTE obviously can handle AD version of particles but when i use SAVE/LOAD the fancy visuals are gone.

fte tries to do its saved games differently, and they're still a little buggy right now (particle effect names are not saved).

In the meantime, you can use the savegame_legacy command instead of the regular save command/menu, which should get it to do its saved games the exact same way as any other engine (and compatible too, except for homedir stuff).
(or set sv_savefmt 0 for the same result, if it exists in the version you're using, not sure when I added that.)
(you should also be able to use it to fix a prior save too.) 
hi spike, i tested your suggestion to change sv_savefmt command and it works.

thanks for quick and helpful reply.

One More AD Problem 
hi spike, i tested forgotten sepulcher more and there is another problem. particles works fine, even after LOAD/SAVE but something else gets broken. gameplay is really choppy after LOAD, however that can be fixed by applying vid_restart

what is more complicated is that already broken breakables re-appears as invisible walls that can not be broken again. i can shoot them, i see impact particles, they bounce grenades and i can shoot them indefinitely but they will not break again.

any idea?

Version Info 
i use win64 client version 5259 
R_glsl_offsetmapping_lod In FTE? 
Spike, I want to try to get up my lazy butt and address your replies later, but in the meantime, I noticed that FTE doesn't have the command r_glsl_offsetmapping_lod and r_glsl_offsetmapping_lod_distance, like DP does. I noticed that it improves performance with bumpmapped textures hugely (especially in large areas) without noticeably lowering visual quality. Any chance of it being implemented in FTE, yes? :3c 
FTE/Afterquake Spotlights In Realtime Rendering 

when I'm trying to use spotlights (both using target or mangle) it seems that this information is ignored in realtime rendering mode for the lights as I get surfaces lit which actually lie outside the desired cone. Static lighting looks correct though - am I missing some option? 
rtlight importing doesn't support all features from maps.
spotlights have been implemented for a while (and sometimes even working), buts its only recently that they've actually been importing from maps - you'd need an svn build for it to work. 
FTE/Afterquake Spotlights In Realtime Rendering 
Ah ok, then I'll probably have to wait a bit longer, thanks! 
Is it fair to say anything that DP can do so can FTE? Put another way, Would it be appropriate to say FTE is a suitable replacement? 
not 'anything', just 'anything that matters' imho.

That said, fte favours more vanilla-type compat than for dp, so don't expect dp-only mods/content to work as-is without obscure cvar tweaks.
cvar reconfiguration sucks. :( 
Good To Know 
For this progs_dump project I am seeing a potentially game breaking bug only in DP and want to direct people to try FTE instead.

I'll address it later (I will need help ofc) but in the meantime, I will steer people to FTE as an alternative to DP for this release.

I think most of my target audience for the mod will be in the QS or QSS world. 
I would think that's a safe bet. FTE is active as well as QS, but with more feature readily available if needed.
Nothing against QS or any other engine, for that matter, people can use what they need. and knowing what is available for their needs only make our world that much better.

Silly Question 
So when using FTEQCCGui and FTEQW how can I force my current config file (the FTE default in My Games) to run? I'm not sure how to configure this when it runs from FTEQCC. The mod I am creating already has a config. 
go into the options dialog, make sure there's no -nohome in the arguments box (those 3 unlabeled text fields are: exe, working directory, and arguments). click save and it should remember those settings next time you run fteqccgui. 
Okay changed that. Getting somewhere but will not accept any changes/saving options in the engine after I launch with F5. I am using fteqw64.exe

Defaults to 640x480 full-screen even if I change and save. As a test I changed my playername and pants/short colors. It did not save either.

When I go to Documents/My Games there's no sub-folder for the mod I am working on. And yes, the mod is loading properly from the -game switch. I am baffled. Shouldn't there at least be a sub folder in My Games? I have a shortcut to the mod directory and my settings are correct when I use that.

One last thing: I have multiple versions of FTE in different folders on my pc. 
Re: -nohome 
I hated this in DP and I hate as well in FTE!

Maybe someone can explain the benefit that actually justifies this behavior, for Quake?

Since it's opt-out, without being clearly obvious no less, instead of opt-in... it's very easy to not understand what is going on with game settings and config files.

Example, after screwing up settings once in FTE and making the game look like trash I just deleted the whole folder and started over as that's the typical way it works. BUT... since I didn't know about this "home" directory shiz at the time... my fresh new game looked exactly the same. This was frustrating.

Having to instantly create shortcut's, or needing to know about adding -nohome into a game launcher(SQL1/2) without any prior knowledge of such Quake config file saving behavior is just a bad decision.

Again, what am I missing? 
Mixed Feelings 
I agree somewhat with damage_inc on this. Perhaps Opt-out by default but write and use fte.cfg instead of config.cfg. Would that work? 
Quake was originally developed for MS-DOS, which wasn't a multi-user OS. MS-DOS evolved into various versions of Windows 3.x, Windows 95, 98, 98 SE and ME, at which time that line was killed.

None of them were multi-user OSs, none of them had security, and this stuff just worked.

Windows NT was developed from the ground up as a new OS and new kernel (that just happened to share some common shell and UI elements with the other Windows). From the very first it was a multi-user OS with proper security, admin/user separation, etc.

Windows NT evolved into Windows 2000, XP, Vista, 7, 8, 8.1 and 10.

The benefits of placing per-user content in user profile directories are:

- These are the only directories that non-Admin users are guaranteed to be able to write to.

- If more than one person uses the PC then your saves and cfgs won't mess up somebody else's, and vice-versa.

So, try playing a stock install of Quake on a PC with more than one user, and logged on as a non-Admin user, and see how far you get. 
There are a big amount of users in different Quake forums reporting difficulties with the fact that configs are stored in a VERY different location.
But we NEVER heard difficulties from people with non-Admin issues or multiple users config issues.

For a simple Quake engine? This modern-OS behaviour is way over the top. It only produces trouble and frustration. And in the end... like many affected users did, they change the engine to a better one without this modern-OS behaviour. --> Like all the other Quake engines have.

Other engines never produce trouble like this. They all work as expected and intended.

The honorable intention to implement modern-OS features into a Quake engine ends up useless and even counterproductive in reality.

So, take a minute and think about it. ;) 
yeah, it sucks. I hate it and always use -nohome myself.

that said, using homedirs is the safe option, even if its not the preferable option.
and its NOT nonsense, there are various installers for quakeworld mods that install into "c:/program files/", which then screws everything up when users try other engines in the same dir. maybe not for the nq community, but it IS a problem for the qw community.
its also very common on linux, too, what with debian/ubuntu's quake package requiring it and all.

windows also has a tendancy to lie about whether access is possible and to then write the files somewhere else that's even harder for the user to find, this makes it really messy to try to autodetect whether homedirs are needed or not.

side note: the afterquake thingie expects the user to unzip and add in some paks, and contains a file to explicitly instruct the engine to disables homedirs (because it doesn't expect to have to fight other installers).

winnt actually predates win95, and unix has always been a multi-user system. this is NOT modern-OS stuff. 
Is FTE networking P2P? Does it have NAT punchthrough? 
yes, but only via the xmpp plugin (the method requires a third-party server to relay messages through in order to establish a connection), and that requires accounts and passwords and urgh, so none bothers with it.

the web port can use an existing/3rdparty fte server as a broker for webrtc (but it needs that 3rdparty server to be configured with eg `sv_port_tcp 27500;net_enable_webrtcbroker 1`). You can then host with `sv_port_rtc rtc://brokerip:27500/mygamename` and connect to that server with the same uri.
I keep meaning to implement something equivelent with the desktop ports, but I can never get around to it. 
Found This On Twitter 
Splitscreen Sound 
By default, the game sound only plays for the left screen (first player). Is there a way to enable sounds for all other screens, too? 
Splitscreen Sound 
switch the audio device away from openal(the default) to any of the other audio drivers (like dsound/wasapi/alsa/sdl), typically via the menu.

openal does its own mixing and only supports a single 'listener', whereas fte's own mixer is smart enough to select the nearest player as the appropriate listener on a per-sound basis. 
That does the trick, thanks. 
Muzzle Flash *issue 
Is it a non-avoidable side effect that whenever I enable r_waterstyle > 1 that I basically lose the weapons muzzle flash?

I state it as "basically" because sometimes I do get the the muzzle flash effect but I can't determine exactly why. And it's sporadic.

Sorry that I don't know the name of the actual cvar, its just the flash when you fire the weapons, explosions etc. 
Broken Coop? 
Hi, I tried to get coop to work with the 5361 Afterquake package and it seems that the server is either not running or it actually starts in single player mode. Deathmatch works fine. Am I doing something wrong, or is there a trick to get it running with some cvars? It worked with a previous version (although I couldn't figure out back then which variable would have set no friendly fire - maybe it was just deathmatch which used my coop player starts?). 
works for me...

make sure you've not somehow messed up any cvars - these are the ones that come to mind:
deathmatch 0 //boo hiss
coop 1 //hurrah! friendly mode
maxclients 8 //quakeworld engines limit clients and spectators separately, which is a little messy.
sv_playerslots "" //auto - 32 when deathmatch||coop, otherwise 1. max of 255.
samelevel 0
sv_progs progs //force preference for NQ gamecode over QW gamecode - QW mods tend to have no coop, in case you have a qwprogs.dat from other sources.

really, the only difference between coop and deathmatch as far as the engine is concerned is that coop is set instead of the deathmatch cvar.

to disable friendly fire, not only do you need teamplay set, but you also need the players to use the same lower colour (in nq). 
I set the values with the console and it worked; maybe the menu command didn't reset everything that was required correctly. 
Pants, he means same color pants so you don't hurt each other. 
FTEqw64 version 5361 isn't compatible with Arcane Dimensions?

I'm asking this because i can't load a savegame when i'm using this mod.

When i press F9 or even loading a savefile from the menu, the engine crashes to the desktop and show me this error message: "Bad Entity Lump: 'Particle' not recognised (last ent was 894)"

Even with "sv_savefmt 0" the engine crashes when i press F9.

I also tried the "savegame_legacy" command, but the console says "Error: hidden name (.sav) Unable to use legacy save format"

help :( 
Is there a way to change console sliding speed to be instant...curious if you can instantly hide the console on map start? 
scr_conspeed 2000(def) increase it until it's near instant. 
Anyone knows if FTE has god-rays auto-generated from the sky?

I remember, a while ago, testing this... i just wrote something in the console and BANG... god-rays from the sky...

but i can't remember the command or even if i was using FTE engine or something else :( 
r_sun_colour ( R G B )

Load up start map and try .4 .4 .4 
Thank you very much =D 
Is there any way to make snow or rain in Hexen2 maps with FTE? 
I could be wrong on this but I'd imagine it's no different than for Quake. Since the particles/configs configuration is engine based and not game based.

So the discussion we had recently about Qmasters 2018_xmas map most likely would apply for Hexen2.

But this time I didn't test it so... ymmv! 
But... to make rain or snow in quake i have to open the map with MarkV, use "tool_texturepointer" to find out the sky's texture name, use "copy ents" to make the ent file, and finally edit the ent file with the sky's name calling the weather effect...

How can i do all of that if MarkV doesn't open hexen2 maps? :/ 
Are you trying this for stock H2 maps? 

here is what i already tried:
i opened the bsp with quark to know the sky name from the first map and i opened the bsp with notepad++ and copied all the ents to make a ent file (i saw someone talking about this in QuakeOne forums) but even with an ent file calling the rain it doesn't work

but the good news is: the second map came with an ent file (i think it's from an update) i edited it and it worked! Now i have rain in there \o/

in other news... it seems the command line "r_sun_colour (R G B)" to make godrays doesn't change anything in hexen2 :/ 
FYI: from he console in FTE "sv_saveentfile"

Will be located in "[.../YourGameDir]/fteh2/maps/"

I used TexMex to open the .BSP to find the sky's name. I didn't get the snow/rain to work on a map load though... I have to exec the .cfg from the console to get it to start! 

Your method will save me a lot of time =D 
Now I see whyyy I didn't have particles on map load, because I didn't have it ENABLED in the particles menu :faceplam: 
With your method i was capable of make rain in the first map. Thank you! =D

One thing i noticed... when you are at the courtyard (player-starting-point) and you look down, the rain stops... when you look straigh or higher (or right down to the floor), the rain starts again :P

This bug doesn't happen in Quake

anyway, i'm happy to see the fte_weather working in Hexen2 :) 
Hi, there!

I'm trying to play FTE with effectinfo (quakespasm-spiked custom particles)... all particles are working fine, except for the blood particles when you hit an enemy. I can see blood particles falling from gibs, but not when i hit an enemy...

anyone has any idea how can i fix this? 
r_particledesc "high effectinfo"
or something. or classic instead of high.
(there's some naming differences that prevents the blood particles from loading) 

"r_particledesc classic effectinfo" is perfect =D 
FTE QW Single Player Is Broken. 
I cannot start a single player game with this client. The paths are all correct in the menu. I have everything where it should be and when i go to play a single player game nothing happens when I try. It doesn't load Quake at all. Whats funny is if i download anything with the quake injector I can play the mods fine. Any help with this weird issue would be appreciated. 
QSS has the same problem. Trying to start a single player game from the main menu does nothing. 
maybe -nohome can help 
I was having issues with singleplayer in the latest build of FTE. Often freezing on level load/change, and sometimes nothing happening on selecting new singleplayer game.

On a suggestion from Spike in the discord I set sv_nqplayerphysics 1 before trying to load a singleplayer map. That fixed the map load freeze. I haven't tried the "new game" selection yet to see whether that is still flaky.

You might or might not already have sv_nqplayerphysics set to 1. I think it is by default, but in the setup you get from the AfterQuake package it appears to be 0. Anyway, if it's 0 for you currently, try setting it to 1. 
Thanks for the responses. Neither command fixed the issue with selecting single player. I added -nohome in a bat file and I also entered the sv_nqplayerphysics 1 in the console. Nothing. What's funny is that in 5399 everything worked fine. The last two updates broke the new game selection for single player. :/ Oh well hopefully the fte qw team is aware of the issue. 
It's A Single Executable 
Why not just go back to 5399? 
Because I deleted it. Can't find it anywhere and the fte qw site doesn't keep old versions on their page. 
BTW, sv_nqplayerphysics doesn't seem to be the panacea for me after all. Weird edge friction going on. If my player model is overhanging a ledge and I tap the walk button once in a direction pointing along the edge, often the player will "grind the rail" all the way along the edge. 
hopefully some of these things are fixed in revision 5424 
Single player fixed with 5424. :) Thanks. Tilding then tapping map e1m1 (or whatever start map) was a little annoying. 
Yah all issues I mentioned above are gone in 5424. :thumbsup: 
RT Lights Are Point Entity Only Yes? 
Without resorting to Q3BSP+Q3map2, is it possible to have in Q1, a texture emit RT Lighting? Using scripts/shaders? 
First | Previous | Next | Last
Post A Reply:
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.