News | Forum | People | FAQ | Links | Search | Register | Log in
The TrenchBroom Level Editor
Today I am releasing TrenchBroom 1.0 for Windows and Mac OS X. TrenchBroom is a modern cross-platform level editor for Quake.

- True 3D editing, no 2D views required
- High performance renderer with support for huge maps
- Vertex editing with edge and face splitting
- Manipulation of multiple vertices at once (great for trisoup editing)
- Smart clip tool
- Move, rotate and flip brushes and entities
- Precise texture lock for all operations
- Smart entity property editors
- Graphical entity browser with drag and drop support
- Comprehensive texture application and manipulation tools
- Search and filter functions
- Unlimited undo and redo
- Point file support
- Automatic backup
- Support for .def and .fdg files, mods and multiple wad files
- Free (as in beer) and open source (GPLv3)
- Cross platform (Windows, Mac OS X and Linux supported)

Check out a video of TrenchBroom in action here.

You can download the editor here.

If you would like to give feedback, please do that in this thread. If you find a bug or have a feature suggestion, please submit them at the issue tracker.

If you are wondering where the Linux binaries are then sorry, but currently there are none. The Linux version has a few problems which I could not fix before this release. I will get working on those right away so that the Linux version should be available in a couple of weeks, too.

Finally, I would like to thank necros for all his work over the past year. Without his tireless efforts, TrenchBroom would simply not exist. Or it would suck.

Alright, enough of this. Have fun with the editor!

Update: 2.1 here:
Features "cool shit".
First | Previous | Next | Last
Thanks Sleep 
I appreciate the reply and the reasoning too. Sometimes we non-coders have no idea how much work is involved for these little asks. :) 
Despite appearances, I appreciate all feature requests and bug reports ;-)

But it's hard to balance it with the greater picture and vision for TB, which is heading from pure Quake 1 editor into a more generic direction to expand the user base, and hopefully, the number of contributors. 
Feature Request 
Auto detect map format instead of failing if Standard was chosen instead of Valve. 
Scale entity labels with icon size or add separate label size option in preferences. 
Remember view settings when reopening TB, e.g. whether to show edges.

Not really sure what to suggest about the dichotomy of having a view menu up top and a view button down lower that both have two different sets of options...combine somehow or at the very least add a dropdown character on the View button for the label like so: View↓ 
When I open up the Trenchbroom, The program is missing MSVCP140.dll. What do I do?!
Did you install Microsoft Visual C++ 2015, like it said on the page? If not, this will do the trick! 
BUG Report: 
When parsing an FGD file, the parser fails to concatenate strings using the + character on tooltip/description texts. Even worse, it fails to load the entire .fgd rather than skipping on to the next valid entry or at least keeping all the parsed entities before it had encountered the error. No entities load from the affected .fgd. Example:

@PointClass base(MonShort) studio("progs/mon_knight.mdl") = monster_knight : "Knight. Uses upgraded AD model." +
" Part of the Death Brigade. Stronger than a death guard but still" +
" useful for early on axe combat. Capable of starting as a statue which uses a stone skin." [
spawnflags(flags) = [
2 : "Stone Statue" : 0
4 : "Not Frozen" : 0
frame(integer) : "Statue Pose def=44" : : "Override statue pose"
pos1(string) : "Statue Idle range" : : "X->Y, Z=0 ; Idle animation range to pick from"

Error message:
Could not load external entity definition file 'games\Quake\JACK_Keep.fgd': Expected '[', but got integer (raw data: '+') [line 2606, column 112] 
Please Report Bugs On Github 
TrenchBroom 2.1.0 Release Candidate 1 

- #871: Add scale / shear tool
- #1304: Add support for Daikatana
- #2279: Add generic game configuration
- #1404: Improve selection and general rendering performance
- #2069: CSG hollow
- #1157: Portal file loading
- #1780: Add "Reload Point File" and "Reload Portal File" menu items
- #1412: Support fence textures with "{" prefix and MF_HOLEY .mdl flag for alpha-masked skins
- #1540: Draw arrowheads on entity links to indicate direction
- #2051: Support merging groups
- #1723: Support for sub-integer grid sizes
- #885: Add button to reload texture collections
- #2276: Add "hint" and "skip" Quake 2 surface flags
- #2202: Add support for FGD includes
- #2329: Add support for string continuations in FGD files
- #2278: Document game configuration file syntax
- #2272: Game path box in game preferences is always blank
- #2256: Don't crash when loading invalid texture collections
- #2254: Don't crash when loading a BSP with missing textures
- #2290: Subtracing a brush that encloses the subtrahend has no effect
- #2297: UV editor crashes if zoomed too much
- #2318: UV editor origin handle disappears
- #2315: Resizing a 45° clipped face yields invalid results

Thanks to everyone who contributed fixes and issue reports! 
Does this release include Quake 3 support? :) 
Quake 3 Is Not Included In 2.1.0 
But I believe it's on the front burner or will be in the near term.

Check this shear insanity. 
Shearly not! That feature is impressive on a scale we haven't seen before!! 
Someone Should Update The Top Post To Include These Features 
Just the fact it shears entity locations alone blows all other editors out of the water! 
Good Stuff Sleep & Eric 
Been using github builds for things like scale/shear for a few months now, they're really useful features. Looking at the other features here, 2.1.0 is shaping up to be an awesome release! 
- #1723: Support For Sub-integer Grid Sizes 
YESSSSS. Gonna ruin everything in my maps with this :D 
Windows Defender Thinks The .exe Is A Virus 
It keeps deleting the file, can't move it or anything. 
Malwarebytes has been wont to quarantine TB2 github builds for me in recent times for me as well, calling them cryptolockers or something when I try and save...

A pain but not a big deal for me. Good luck with figuring out how to whitelist things in Windows Defender 
After installing the visual pack, I attempted to run Trenchbroom but it shows me that error. HELP! 
Virus Total 
says it's clean. 
Windows defender identifies the file as containing a trojan "win32/Azden.b!cl"

Not sure what is going on but I can't seem to get around this as the files are immediately quarantined. 
seems to be a heuristic detection, surely there's some way to whitelist it in WD? 
I get the same trojan warning in Win 10, with the latest windows defender data (today's). 
I Filled Out The Form To Report False Positives 
New Version Is A Game-changer 
Just when you thought the most epic open source project of all time couldn't get any better ... the new version is amazing. Thanks, as always. 
Most Epic? 
If you count features, lifespan, and number of users, Blender clearly wins that crown. But yes TB is awesome and more awesomner than ever. 
I got a response back from Microsoft saying they fixed the incorrect detection. Not sure how long it will take to make it into the windows defender virus definitions but they seem to be updated daily, so hopefully it's fixed soon. 
I Know Exactly What To Do With The Shear Tool 
OMG! Daikatana Support! 
Gonna make some maps full of dragonflies and frogs and create plenty of places for the sidekicks to get stuck. 
Lovin' It. 
Just wanted to say I'm really loving Trenchbroom and to thank you for all your hard work. Moving from the ancient Hexmaker editor, TB has revitalized mapping for me. The ability to select and edit multiple brushes at once is a HUGE time-saver and really makes things so much easier, not to mention the great 3D view functionality. I also find the face clone/extrude function very useful in setting up the initial arrangements of complex brush arrangements, in fact I think I actually use it more often than the brush creation tool.

Anyways, here's a imgur album of the Hexen 2 map I'm working on:
It's getting pretty huge because of the BSP2 support I found in a custom version of uHexen2, but the use of detail brushes actually lets me do a full level 4 VIS compile in under 1 minute. O.o 
Wow! A new map for Hexen2? And it looks awesome!!

I can't wait! =D 
I love hearing these stories! 
You need to port that map for Quake at one point, looks great! 
WOW. Keep us posted on that map!!! Also, are there any communities for HeXen 2 mapping online or on Discord? I'd like to lurk around a bit. 
H2 Community 
Thanks everyone!

@dumptruck_ds Afaik it's pretty sparse for H2 mappers, I've mostly been doing this on my own, but I'd love to find a group as well. 
Well I'd be happy to have you join us in the Quake Mapping Discord if only to keep in touch and maybe pick your brain about H2 mapping when the time comes (next year likely). 
TrenchBroom 2.1.0 Release Candidate 2 
Fixed Link 
@Razumen @dumptruck_ds 
Yesterday i've found a new Hexen2 custom map (released last month) made by Whirledtsar.

I think this is the first HX2 map made in TrenchBroom that i ever played =D


my playthrough: 
I mean don't get me wrong, I'll be the first to axe every wierd wall but that was ridiculous. Are hexen levels always that obtuse? Never played it. 
I played Hexen2 in 1997, so i don't remember if you had to do it on the original maps. But on the custom maps, people usually hide secrets behind destructible walls (or bellow the beds, or behind a bookcase, or inside a statue, etc) so you have to axe everything to find them. When something is destructible there's a particular sound that it makes when you axe it, so it's not that hard to know if you can do it or not... but it's just boring :P 
TrenchBroom 2.1.0 Release Candidate 3 
Fixes the registry corruption bug and a few others: 
@ Tribal 
Looks interesting, I'll have to give it a spin.

@Qmaster Original H2 wasn't really obtuse with its secrets, mostly they'd be hinted at in some way. Generally I find hiding secrets behind things with no hint at all that there's something there just bad level design, even worse if progression relies on it. No way in hell I'm going to go hitting every wall to see if it's breakable. 
@Razumen @Tribal 
Razumen - that looks excellent! The lighting is very nice and the setting looks very interesting. Can't wait to play it.

Tribal - thanks for playing the map, hope you enjoyed it! Yeah, the progression is a bit cryptic, but I'm the kind of guy to destroy everything breakable on principle so it didn't occur to me that it could be a problem for others. 
TrenchBroom 2.1.0 
Specifying Skin And Model From Dfferent Folder/pak Directories? 
Does anyone know how to do this? Hexen 2 has paks in a different directory for mission pack monsters. I thought copying over the pak file to data1 would be a bandaid solution, but it just crashes Trenchbroom. Do I have to specify an absolute path for these special entities or is there a cleaner way? The vanilla entities load their models fine in TB.

Also, is there way to specify the skin to use for each model, H2 has certain monster variants that use the same model but different skins. Not as big of a deal as above if I can't, but would be nice.

Not too familiar with the FGD format. 
RE: Specifying Skin And Model From Different Folder/pak Directories? 
Nevermind about the skins, figured that out. 
You Need To Add The Mission Pack Directory As A Mod 
And you need to create a new fgd for the mission pack. You can reuse the existing fgd by including it. If you do create an fgd for the mission pack, please make it available to us so that we can include it.

You might get lucky if you google for it, maybe someone has already created one. 
Thanks! I must've missed that part of the manual. 
TrenchBroom 2019.1 
Get it here as usual:

This release contains experimental Quake 3 support. You can load Quake 3 maps with shaders. But patches and brush primitives are currently dropped and md3 models are not displayed in the editor. 
Wow - It Was Close To Release! 
Time to find my old maps! 
How Stable Is Valve Format (on Linux) These Days? 
I haven't touched TrenchBroom in well over a year and am out of the loop, but now I'd like to slowly but surely get back into mapping, if real life allows.

When I last used TB, I kept running into problems with texturing. Using Valve format would often result in bizarre problems and I had to convert everything I was working to Quake format, but even then, copying and moving brushes would often result in completely messed-up texture properties. This was one of the reasons why I gave up on mapping for a while, as it was incredibly time-consuming to have to manually fix the texturing on individual brushes; it almost defeated the purpose of copy+paste.

I don't know if there are any differences between the versions of TB for the various OSs, but those of you using TB on Linux, how is texturing in TB these days? And how stable is Valve format in the latest iteration of TB?

I apologise if this sounds like one of those things one could find out for oneself, but I am reluctant to go through the same process again of needing to restart or redo hours (or days/weeks/months) of work and completely spoil the fun of mapping for myself ... again. 
I'm Not Aware Of Such Problems 
There have been a few changes and fixes for Valve 220 texturing last year, but I'm not sure if these are related to what you are describing. Did you submit bug reports for these problems? 
What's My Problem ?

I cannot get the map to compile.
The directory has full permissions

Well, export map has no map name?

I haven't used the built-in compiler in a while but the manual says:

Exports the map to a file. This file should be different from the actual file where the map is stored. 
Thanks For Responding, SleepwalkR 
I guess I would have submitted bug reports (I have submitted a few over the years), but my memory is a little hazy; as I said, I've been out of the loop for a while.

I do remember using ericw's tools to convert a few maps to Quake format the last time I was actively mapping and I think it was on either ericw's or your advice, since at the time, the were some problems with Valve format and regular Quake format was a lot more stable.

I seem to recall that when using Valve format, selecting a bunch of adjacent brushes and giving them the same texture values wouldn't work and would result in horribly misaligned faces (e.g. with rockwork or even just fairly simply architecture, like a brick texture wrapped around a tower).

But I also remember that even when using Quake format, textures wouldn't stay properly locked or would come out weirdly flipped when I moved copied brushes around (I think especially when flipping them). This was especially annoying when I had spent a lot of time fiddling with exact angles and X/Y values to get textures looking right on angled surfaces, only to find them completely messed up when I copied and moved the brush in question somewhere else.

I'm sorry that all of this is rather vague. 
You've set up your compile so that it does absolutely nothing, you need to specify what each tool has to do.
Go into the Trenchbroom help (F1) and look at the Compiling Map section, there's an image suggesting how you should set up compiling. 
It's Impossible To Say 
without having proper steps to reproduce. But the fact that noone has submitted bugs in the issue tracker tells me that there are not a lot of people who experience such problems. 
probably something stupid, but
having an odd issue with TB Version 2.1.0 RC1 release
started dinking around in a map. Was going dandy. Was compiling with Necros GUI. Dandy. Then I noticed changes made weren't making it into the compiled map. Stopped for a bit. Turned PC off. now when I try to load map, I get notification "unexpected end of file".
windows 10 home

Pls let me know if any input to resolve. Not a big deal with this particular map as its tiny 
the fact that noone has submitted bugs in the issue tracker tells me that there are not a lot of people who experience such problems.

Fair enough. :) Thanks again for responding. Well, I guess worst case scenario is that I do run into these issues again, in which case I'll submit bug reports. 
Please Do 
We are usually quick about fixing those. Thanks! 
What Does The $ Mean? 
what does the $ mean? 
Starting symbol for placeholder string.
For example, in line above substring $(MAP_BASE_NAME) will be replaced with your map name. 
And to be clear, TrenchBroom will do that substitution automatically. You shouldn't actually type your map name in there. Instead, type $(MAP_BASE_NAME) exactly as it is showing you. 
Is It Parentheses Or Braces? 
I forget, but I thought it was ${BLAHBLAH} with braces? 
Yah I didn't have the manual handy, just copying what they said above. But it is in fact braces like ${MAP_BASE_NAME} 
Is Post #2895 
being ignored cuz I'm dumb? Or did it just get skipped over in the midst of the $$$ 
The Problem Is 
more then I can bear. Not really I just liked writing it. I do appreciate the posts. I am a tad closer but not there yet. I find it difficult to converse in a language I am not functional in. The more I study it and look at examples from other compiling sources the closer I think I am getting until I attempt implementation. I did print out the compilation dialog
from JACK and Quark. Those sources and the Trenchbroom manual may be speaking the same language but I don't know how many ways the same thing can be written. AS my genetics professor once remarked..."Don't make an easy thing hard" Nyuk, Nyuk, Nyuk 
Try to open your map in notepad and save. It is good to make backup before. If we talk about map not bsp. 
you can check your map format structure as plain text or share it 
This video is closed caption so you can watch in your native language: 
Can you upload the map file and post a link? 
The link takes me to your setup tut 
YES!! it is a video that you can play in your native language as I typed above. The section where the compiling is setup should play automatically. 
Referring To This Comment 
I find it difficult to converse in a language I am not functional in.

Maybe I misunderstood. 
thanks for interest/reply

trying to remember what I was doing that could have triggered this weirdness but it's a little unclear as I didn't realize it wasn't making changes for bit (assumed I messed up in the editor as it isn't my comfort zone etc)

please let me know if more info required 
Why Doesn't Someone Write A Tut For Compiling Q2 Maps Out Of 
Trenchbroom? I have seen two other threads that fizzled when the user was asking for help to do just that. I am wondering if there is an issue with Trenchbroom that won't allow for it. Heck, if there was one for how to do it with Quake that might suffice. I am hoping someone takes up the challenge. As for the statement "I find it difficult to converse in a language I am not functional in. " I was referring to my inability to understand even basic code speak. 
I did it before. It can be done. Just try it out. If I can figure it out anyone can. Sorry I don't have the answers for you but I have a new computer and those files are on another I don't have access to. You can Google for Quake 2 compiling tools and find this:

Write a batch file to compile your map and FFS GO MAP. 
and go here for some info: 
The map file looks fine. Could you post the entire error message, it might stem from one of TB's other configuration files. 
I've got it

// entity 25
"classname" "monster_zombie"
"origin" "744 136 200"
"angle" "270\"

Last entity at file has misprinted backslash - escape character. Just remove it using notepad. 
Good Find! 
Appreciate it. Thank You. Too much for me though. I am now using Quark's internal compiling. It is no more time consuming then using the compiling GUI. So I build in Trenchbroom and compile in Quark, my problem is solved. 
Mission Accomplished. 
(re #2918 AND #2920, clearly)

So is this \ a byproduct of something I did in the editor or just my fat fingers 
Drew A.k.a. Fat Finger 
Seems like you pressed it in pair with Enter 
TB should warn about this though. 
You have to validate string on focus lost at least. BTW only useful escaped symbol for entity fields is "\n" 
What he said 
TrenchBroom 2019.2 
TrenchBroom 2019.2 is out with md3 support and some fixes and performance improvements | 
TrenchBroom 2019.3 
TB 2019.3 is out with several bug fixes: 
Hiding Vertices/edges/faces Behind Brushes? 
Is there a way to do this, or in the works? The screen can be a real mess when working with a lot of grouped brushes. 
I Don‘t Understand What You Mean 
Please explain in more detail. 
Re: I Don‘t Understand What You Mean 
Ah sorry, I see there's already an issue open under "Draw occluded vertex handles shaded #1568" detailing pretty much the same request. 
imagine how cluttered it got when Vertex, Edge, and Face nodes were all displayed at the same time. 
Quake 3 Bug 
I am sorry, may be I am just stupid but seems like I found a strange bug. When I open quake 3 .map in TB and then save, it turns into quake 1 map (I use windows version of TB 2019.3). I asked few people to do the same on their PCs and they have same bug. Seems like TB converting quake 3 maps into quake 1 format when it opens it. 
Also Quake 3 Bug 
Also wierd bug. Not all md3 models are displayed in TB. Check it out, here are some models that I use: 
Wad3 Textures 
Seems like wad3 textures can not be loaded in TB 
Q3 Maps 
As per the output in the log, TB does not fully support Quake 3 maps. Quake 3 maps are Quake 2 maps with two additional structures: Patches and brush primitives. Neither are supported, so when you save a map, these structures will be lost.

TB also won‘t display models that consist of multiple md3s that are connected by tags, or models with external skins.

The Quake 3 config expects tga, jpg or png textures. WAD3 is a Quake 1 thing, if you want to use it, you need to create a custom game config. See the manual. 
Wad3 Support 
Got wad3 textures with this confing
"textures": {
"package": { "type": "file", "format": { "extension": "wad", "format": "wad3" } },
"format": { "extension": "C", "format": "hlmip" },
"attribute": "wad"
So I Hear There's A New Quake Engine-based Game Announced. 
Might be a good opportunity to hype up Trenchbroom and get new people interesting in Quake modding and mapping. ;) 
I think this release will be huge for our community. 
Rotating 2D View? 
Is this is secret feature or a bug? It's happened a couple of times now while I've been editing but not sure how. 
I Don‘t Know What You Mean 
How does it rotate? Did you take a screenshot? 
TrenchBroom 2019.4 
As If It Was Rotated 180° 
I'll take a screenshot and create issue if it happens again, as I'm not quite sure how to reproduce it yet. 
Oh, I Was Using 2014.4 RC1 
I'll update and see if I can repro it. 
I'm using Trenchbroom for my UE4 game and I just wanted to say thanks to you SleepwalkR. This is the most intuitive and fun map editor out there. The fact that its open also allows me to tweak stuff to my workflow and it works great. 
Glad it is helpful to you! 
TrenchBroom 2019.5 RC 1

Adds support for ASE models, greatly improves model loading times, you can now click the model to select an entity. Also fixes an out of memory problem on Windows when opening a lot of large pk3 files. 
TrenchBroom 2019.5 RC 3

Improves the rotate tool and fixes a number of bugs! 
Textures Not Shown In Browser 
Hi. just installed a fresh version on win10 and created a new q2 map, but textures are not shown in texture browser, only black squares with names. any suggestions on that? 
looks like this bug is only in 2019.5 RCs, 2019.4 works fine 
TrenchBroom 2019.5 RC5 
TrenchBroom 2019.5 RC6 
There was a bug that would result in TB not reading its preferences. RC6 fixes it: 
TrenchBroom 2019.5 
Adds ASE support, better rotate handle and visual improvements.

Get it here: 
TrenchBroom 2019.6 
Bug Report 
Hello, I am working on one map in q3 format. I updated TB (sorry, I do not remember which version I had before). Now when I open the map it just crashes. And here is the crash file:

OS: Windows 7 (build 7601, Service Pack 1), 64-bit edition
wxWidgets Library (wxMSW port)
Version 3.1.1 (Unicode: wchar_t, debug level: 1),
compiled at Feb 18 2018 18:36:35

Runtime version of toolkit used is 6.1.

GL_RENDERER: Intel(R) HD Graphics 4000
GL_VERSION: 3.3.0 - Build
TrenchBroom Version: 2019.6
TrenchBroom Build: v2019.6 Release
Reason: std::exception: bad allocation
Stack trace:

I renamed the textures folder so the editor could not find it and now the map can be opened! After that I disabled all texture collections on the map and I gave the correct name for textures folder so editor could find it. After I add one texture collection by one and in one moment the map crashes again. I dont know how it works. May be the editor has some limitations for allocated memory. How can I fix that? 
Can you post the map that crashes at please? Using any .pk3's with third party textures or all stock q3 textures? 
Yes Post An Issue Please 
I suspect you are loading too many texture collections and run out of memory. Please also post your machine specs such as how much memory it has. 
Reply To Ericw And SleepwalkR 
Hi! Thanks for reply!

In editor I am using textures, which are located in folders, and I dont use any archives for editing maps. I am using my own textures. I thought that the problem can be in one of the textures (may be format is incorrect or some texture crashes the editor by some other reason). So that would mean that some of my texture catalogues contain the "problem" texture and I tried to find it. But each catalogue (folder with textures) can be opened freely without any crashes. But if I try to open more than 3 texture collections the editor crashes. Seems like the problem is in allocated memory

My laptop is 7 or 8 years old but I dont think that it has not enough memory to open the map. I have 8 gb of RAM, intel core i-7-3600 processor and Geforce 650m (idk if this information is needed).

I wonder if there are some limitations for the RAM that can be used in editor? If yes, how can I change it? 
How Many Textures Are You Trying To Load In Total? 
Also Can You Give A Total Of The Disk Space That These Textures Occupy 
Textures occupy 465 mb of disk space. There are 1034 textures in total 
2 posts not shown on this page because they were spam
First | Previous | Next | Last
Post A Reply:
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.