News | Forum | People | FAQ | Links | Search | Register | Log in
"New" Q2SP: Citadel V3.0 Released
Hello everyone, long time no see. Some of you may remember Citadel, a Quake II unit that I released in 2007 (version 2.0 came out in 2009). Two years ago, having noticed that my levelpack had disappeared from the web, I decided to bring it back to life, but this is more than a re-release. Citadel 3.0 contains two more maps than the previous version, bringing the total to nine (eight regular levels and a secret level). All the old maps have been revised and re-compiled, with more or less evident changes in visuals, layout and gameplay. For those of you who have never played it, Citadel is an old-style unit featuring a wide range of entities from Ground Zero, The Reckoning, Zaero and Lazarus, along with completely new entities. I hope you will enjoy this levelpack, comments will be most welcome.


Download Citadel for Quake II (31 MB)
http://www.mediafire.com/file/nl5aoxuasj2pvz5/citadel.zip


Screenshots
https://i.imgur.com/nyaFouv.png
https://i.imgur.com/cXzvA7t.png
https://i.imgur.com/wMfuhSX.png
https://i.imgur.com/JIpqRpc.png
https://i.imgur.com/XtBFvoJ.png
https://i.imgur.com/rtjZ80O.png
https://i.imgur.com/Bd5T7HF.png
https://i.imgur.com/SFCLert.png
https://i.imgur.com/3GbBu2N.png
https://i.imgur.com/NfnfEF8.png


VERY IMPORTANT NOTE: Citadel is not compatible with Knightmare, because it contains special entities that are not recognized by the custom engine. If you play Citadel under Knightmare the game will apparently work, but at some point you will end up stuck since critical entities are missing. If you have Knightmare installed on your computer you can still play Citadel: carefully read the instructions on how to setup the game in the correct way.
IDontRealCareThatIamPostingFirst 
Is there anyone willing to make an idiot-proof config/executable to make this run on kmq2? 
 
"Is there anyone willing to make an idiot-proof config/executable to make this run on kmq2?"

It's not a matter of .cfg files, what would be needed is a new kmq2gamex86.dll incorporating the new entities. Some years ago I talked to the author of Knightmare about this subject, but things didn't evolve past the hypothesis stage. 
 
Goddamn, apparently I was playing this 10 years ago. Will give it another go. 
As Soon As I Finish My Jam9 Map 
Totally streaming this. One of my favorite releases for Quake2, with added levels and polish? I'm in. 
I'll Be Playing This Tonight Using The Yamagi Source Port 
It seems to work with most mods and custom maps I've tried so far. I'm confident it'll work with this custom unit, and if not, I know the devs will be quick to make it work =)

Thanks for making this Andrea Rosa; the screenshots look awesome! Long live Quake II! =) 
YEEEEEES! 
Best Quake II unit.
Played with YamagiQ2 
Source? 
Without the source to recompile, this is useless to everyone but win32 users. 
 
Without the source to recompile, this is useless to everyone but win32 users.

The source will be available soon, stay tuned!

Also, version 3.1 with 100% Knightmare compatibility will be released in a few days. 
Yes! 
One of my favourite Q2 units, I am really looking forward to play this enhanced new version! 
 
Citadel is now fully compatible with Knightmare. The download link has not changed:

http://www.mediafire.com/file/nl5aoxuasj2pvz5/citadel.zip

Also, the source code is now available (courtesy of Knightmare)

http://www.mediafire.com/file/7rdyw0zlhhtmb1p/kmq2_021_source.zip 
Nice 
Will need to give this a go. Need more quake2 SP maps! 
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.